Nextcloud 27.1.3, Talk without GPU acceleration = BUG?


I am aware of posting config and system specs is “required” when posting for help in the community. But I am not really asking for help. My server instance is working as close to 100% ok as i could want.

However, i have 1 single user that have an 7-8 years old computer that does NOT have hardware gpu acceleration. He complaints that TALK is lagging and quite slow. Server has been running for years at v24 without any issues in TALK.

I have a 5 year old Macbook PRO and it works fine. However if i go in Chrome / System and turn off the “User HW acceleration when available” I managed to reproduce his scenario. Things are then lagging, and really not “comfortable”.

I can understand that Nextcloud devs “expects” users to have rather new computers, but at the same time I wonder if this might be a bug?

Did anyone else notice this behaviour?

I have for hours tried to tune configs, but to no success for him :frowning:

I would appreciate any feedback form experience you guys might have.



don’t get me wrong here, but you’re doing exactly that :sweat_smile: people here on the community are happy to help to answer questions, give recommendations or just discuss things. Most of the time the answers are dependant on the version, the system or the environment. Constantly trying to get (the same) information is super annoying, that’s why the templates exists and it’s considered best practice to fill them out to the best knowledge. Of course this can vary depending on the situation and not all information are needed.

Anyway, that being said, talk does not expect anything by default. We rely on APIs of the browser for access and managing the streams. So if the browser expects something, then this would affect talk as well. Although it’s probably fair to assume, that the devs don’t test on a 7-8 year old device.

A switch was added that could reduce the gpu performance needed, while in a call, you could check that out: could help if the performance issue is only on calls .

Otherwise you could try to optimise settings on the signaling server, but it’s not clear if you’re even using it.

It would have been quite interesting to know what you tried already

1 Like

Thanks for your reply but i only wanted to know if someone has the same problem with heavy lagging when typing text and scroll in talk with deactivated hardware GPU acceleration using browsers to confirm its a bug.

It surely must be possible to ask that before pasting all config(s) ?
And I am not using video in Talk. Also not using any signaling servers.

And before i post the configs I can inform you that my settings is latest ubuntu 22.04, PHP-FPM 8,2, Redis… Mostly followed Nextcloud recommendations.

Thank you.

Nobody here that could do me the favour and test how chat functionality in nextcloud talk (using browser) works out when GPU acceleration is turned off?

The switch is found here:

Simply write some messages, scroll a bit up and down… lagging?

I know nobody else to ask running a nextcloud server :frowning:


When switch off hw acceleration, not only Talk lags, but everything.


Thanks for checking (appreciated !).

Then you get the same results as me. I have tried for hours to tweak things, but with no success. I am sure this can only be fixed by devs. I am not going to hold my breath for that to happen though :slight_smile:

Again, thank you :+1: