Nextcloud 27.1.3, Collabora Online, Nginx Proxy Manager

Hi, im having issues to open documents with collabora, im using nginx proxy manager for all my ssl certificates, when i go to settings/admin/richdocuments it says my server is reachable, when i go to hosting/capabilities i get {“convert-to”:{“available”:true,“endpoint”:“/cool/convert-to”},“hasMobileSupport”:true,“hasProxyPrefix”:false,“hasTemplateSaveAs”:false,“hasTemplateSource”:true,“hasZoteroSupport”:true,“productName”:“Collabora Online Development Edition”,“productVersion”:“”,“productVersionHash”:“5093121”,“serverId”:“31530d26”}, i even tried to use a demo server and my documents wont open, i dont know what else to do so im asking here to see if someone can help me

system information

Nextcloud version (eg, 26.0.1): 27.1.3
Operating system and version (eg, Ubuntu 22.04): Ubuntu Server 22.0.4 LTS
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.52
PHP version (eg, 8.1): 8.1.2
Database (sqlite or MariaDB or Postgres) MariaDB
Is this the first time you’ve seen this error? yes

The issue you are facing:

  • Steps to replicate it:
    I try to open a document and it wont load all i get is Document loading failed

  • The output of your Nextcloud log in Admin > Logging:

  • The output of your config.php file in /path/to/nextcloud**
    (use https://.../settings/admin/support which auto-removes identifying information!):
    "instanceid": "***REMOVED SENSITIVE VALUE***",
    "passwordsalt": "***REMOVED SENSITIVE VALUE***",
    "secret": "***REMOVED SENSITIVE VALUE***",
    "trusted_domains": [
    "datadirectory": "***REMOVED SENSITIVE VALUE***",
    "dbtype": "mysql",
    "version": "",
    "overwrite.cli.url": "***REMOVED SENSITIVE VALUE***",
    "dbname": "***REMOVED SENSITIVE VALUE***",
    "dbhost": "***REMOVED SENSITIVE VALUE***",
    "dbport": "",
    "dbtableprefix": "oc_",
    "mysql.utf8mb4": true,
    "dbuser": "***REMOVED SENSITIVE VALUE***",
    "dbpassword": "***REMOVED SENSITIVE VALUE***",
    "installed": true,
    "htaccess.RewriteBase": "\/",
    "default_phone_region": "US",
    "memcache.local": "\\OC\\Memcache\\Redis",
    "memcache.distributed": "\\OC\\Memcache\\Redis",
    "redis": {
        "host": "***REMOVED SENSITIVE VALUE***",
        "port": "0"
    "maintenance": false,
    "theme": "",
    "loglevel": 0,
    "trusted_proxies": "***REMOVED SENSITIVE VALUE***",
    "mail_smtpmode": "smtp",
    "mail_smtpsecure": "tls",
    "mail_sendmailmode": "smtp",
    "mail_from_address": "***REMOVED SENSITIVE VALUE***",
    "mail_domain": "***REMOVED SENSITIVE VALUE***",
    "mail_smtpauthtype": "LOGIN",
    "mail_smtpauth": 1,
    "mail_smtphost": "***REMOVED SENSITIVE VALUE***",
    "mail_smtpport": "587",
    "mail_smtpname": "***REMOVED SENSITIVE VALUE***",
    "mail_smtppassword": "***REMOVED SENSITIVE VALUE***",
    "app_install_overwrite": [

I’m seeing the exact same problem after upgrading to 27.1.3 (from 27.1.2), document was opening fine on monday and is now spinning for ever (I waited up to 45 min so it’s like there is not timeout, weird) on tuesday … I’m on Apache, Debian 11, PHP8.2, MariaDB, …
I had errors relating to ClamAV (which I do not use), I deactivated the AntiVirus app, I’m getting an error but I’m pretty sure it’s not related (OC\Authentication\Exceptions\InvalidTokenException: Token is too short for a generated token, should be the password during basic auth …)
I sometimes really wish we would have less releases and more stability, each time I’m updating I have to do something to have Office working … but this time it’s not working (uninstalling, reinstalling, opening existing doc, creating a new one, …)

please check the the wiki primarily addressing dedicated installation Nextcloud Collabora integration but lot of hints available for collabora-built-in as well

Iv tried already all those and im getting a result on all of those test, i also must clarify that both collabora and nextcloud are running on apache2 on the same machine, as it is the nginx proxy manager, if i use my collabora server on a diferent nextcloud at a diferent domain it works, but on the same domain it doesnt.

for example i have 1 ip address using a noip dydns domain of for example, 2 nextcloud servers on 2 diferent machines , one of them is and, a collabora server hosted on server 1 with, if i try to use it on nextcloud1 or 2, it wont work, gives me the socket error thing, but! if i try to use office1 on a diferent nextcloud that is hosted on a diferent ip/domain for example, then it works like a charm

I was under impression you are using built-in CODE but from you explanaition it looks you are running separate CODE installation.

this makes no sense for me. It sounds you experience networking issues like DNS, routing, firewall… but If you successfully run all the tests in the above WIKI connectivity checks all the issues are addressed. You must show more details from your config, troubleshooting steps and logs from applications and proxy so we can better understand your setup and problem.

I know right? makes no sense for me ether, iv been searching online and some ppl say i cant have collabora and nextcloud running on the same machine for them to work, others say is possible, i know it is because i have a third server runing nextcloud and collabora on the same server without any issues, so im guessing it has something to do with nginx proxy manager, but i cant find a solution for it :frowning:

Oh btw, i also tried downloading the built-in CODE server app, but when i click on the built-in CODE option in the nextcloud office app, it says it cant connect to the server :frowning:

you definitely can run both NC and CODE on the same machine. I can’t tell you what is the right config for bare-metal but my Docker install works since years on the same machine but uses different DNS records for NC and CODE (which I assume is the case in your setup as well).

Well i set everything up again and now its working, i dont know what was the real problem but its working now with everything fresh :upside_down_face:

1 Like