Nextcloud 25 with truenas scale - access from outside network - no JAIL

Nextcloud version (eg, 20.0.5): 25.0.1_19.0.11
Operating system and version : TrueNAS-SCALE-22.02.4

Can’t seem to find how to get the nextcloud to allow off network access. the Truenas scale support of Nextcloud doesn’t have “JAIL”; the SHELL on the app needs intermediate or better understanding on coding (no guidance I can find online) and the WebGI of nextcloud doesn’t have an option I can find as well.

To be clear, i am really NEW with Nas and linux based operations. Networking knowledge is less…

What I have done so far:
-I have a DDNS from FreeDNS (‘name’
-Open port 80 and 443 on my router with the IP of Nextcloud

unsure about:

  • if my router settings is correct
  • enabling ingress (why?) and how to find the info to put in there
  • where can i find the WebGI or how to find the path from the shell for TrueNAS Scale to tell nextcloud to allow me in.

Please see photos below.

Thank you for your time.

Nextcloud (and TrueNAS) don’t have any control over your router’s port forwarding. If you can access from your LAN but not from the internet, then something in your network settings isn’t right.

I can’t really tell from your screenshots, but I suspect you shouldn’t have a CIDR /16 network in your trusted proxies list. Are you even using a proxy?

The numbers in the trusted proxies was auto populated. The 7 different instructions I went through, all said to not change the auto generated ones.

Right now, I think the biggest issue, nextcloud on truenas Scale doesn’t have JAIL. At least, that is the biggest difference from all the guides and instructions I have seen.

Do you have any insite where I can plug in my ddns and basically the IP and port info that someone on Truenas Core would do?

Normally this option is not populated at all unless a reverse proxy is in use, and then only the specific IP of the proxy, not 65536 IPs. Without having seen these guides, I can’t say why they might do that.

I’ve never used the TrueNAS version of Nextcloud, so I can’t say about that.

Nextcloud doesn’t manage DDNS, so this will have to go in whatever device is handling that.

Are you asking me to post the guides I’ve been following? It’s a lot. Lol.

I think I’m not using effective writing here. The ddns is managed by the host, which in my case freedns (if I’m understanding the term managed correctly).

In truenas core, you use the ‘Jail’ WebGI or edit the config file from the ‘shell’. In Ubuntu OS, you directly edit the config file. With Truenas scale, There isn’t a spot on the webgi I can find and the shell option pathway doesn’t bring me to the config file and the system editing option on the app icon doesn’t have DDNS edit options like truenas scale version 14 (iaw YouTube guide)

My understanding -

  1. freedns manage the ddns address to say, ‘’ will go to ‘numbers’ IP address (I didn’t buy a domain). In my case, the nextcloud populated IP address, not the server IP address. (That part is confusing cause one screen on nextcloud saids it is my server IP with port XXXXX, but the webgi says it is a XXX.XX.X.X./16.).

  2. Need to open the 80 and 433 ports in my router.

  3. (Can’t find the location of this) find the config file for nextcloud truenas scale or on the nextcloud webgi to allow remote access by plugging in the IP information.

Nextcloud and my server has nothing in it yet, so if I need to delete, reformat and start all over, I will not lose anything.

I don’t really understand what you’re saying here.

This part doesn’t make sense to me because you don’t have to add an IP address to the config file to allow remote access, unless this is something specific to the TrueNAS version.

If Nextcloud is running, the only things you should need for remote access are the port forward and DNS.

No worries. I’m with my family in cologne for the holiday. Once I get back, I’ll screen shot and drop links.

I’ll also look up how to do this with Ubuntu and Debian more. As truenas seems to be based off of it.

Oh no, not at all. TrueNAS isn’t even Linux.

Acutally no, TrueNas Scale is based on Linux but all of its applications run in Kubernetes IIRC…

However TrueNas Core is based on FreeBSD IIRC…

for me all of that sounds more like a TrueNAS problem rather than a NC-one

1 Like

Hey everyone.

So i made some headway and now can see the Nextcloud screen from my DDNS, but stuck at my subdomain (DDNS) is not a trusted domain.

The sad thing, the truenas SCALE is based on a GUI idea and should be idiot proof (I made sure that isn’t true). I followed every possible way of adding my ‘’ DDNS to the congif_php file, but TrueNAS Scale makes it impossible to find and edit this file.

-I tried going through the TrueNAS CLI Shell option on the server

-Tried going through the Linux Shell option on the server

-Tried going through the Shell by TrueNAS/systemsettings/shell. was able to get to nextcloud files by : “sudo docker exec -it $(sudo docker container ls -q --filter name=k8s_nextcloud_) bash”. but “#vim /var/www/html/config/config.php” doesn’t work. editing config/config.php = permission denied…

-tried looking through the GUI of the “nextcloud” app/edit settings. nothing there to help.

-also tried going through the SHELL of the nextcloud app it’s self. claims i have zero permissions to do anything there.

any suggestions?

im posting in TrueNAS as well, but figure this shouldn’t be a new issue for this soundboard.