Nextcloud 25.0.5 docker container missing

Albeit Nextcloud 26 and 25.0.5 got released (almost) simultaneously, there’s still no docker container for 25.0.5 while the NC 26 docker container got published.

Is there usually a longer wait time for bugfix release container?

1 Like

I think the latest patch of version 24 was also missing when I was checking for updates yesterday. It looked like the patch was released about 3 days prior.

I’m not sure what the normal lag time is for the containers, but it shouldn’t be too long.

1 Like

Same issue here. Updated Nextcloud and wanted to replace the container with the new image, as I always do - no image there. Therefore my Container is not starting anymore.

Maybe create an upgrade checklist that includes the task of checking container availability beforehand :slight_smile: Just an idea

Luckily it is just an private instance. But you are absolutely right that already happened a couple years ago and since then I checked it, but recently stopped of cause… :smiley:

Why would your existing container not start just because no update is available?

1 Like

So that error indicates you actually did load a 25.0.5 image and then downgraded to a 25.0.4 image. I’m not sure how that would have happened if no such image had been published.

Could you post your entire update procedure start to finish?

1 Like

That error indicates that my Nextcloud data is on version and the image I have is only I was able to update Nextcloud to 25.0.5 via Web Updater, without the docker image.

My update procedure:

  1. Get a notification that a new update is available.
  2. Wait 2-5 days (In the future: + check if the image is also available).
  3. Update via Web.
  4. Restart the container with the new Nextcloud-Image (matching version).
  5. Done.

In theory you do not need to do Step 4 if your Nextcloud Container is running 24/7, but if there is some power outtakes or so it will restart and have an old image version and it will not be able to start anymore, since Image and Data version differ.

Okay so this right here is an issue. The docker image doesn’t use the web updater. You just swap the docker image.

1 Like

I have been doing this for years and most of the times it just worked flawlessly (when there was an image).
Will the Container even start with a newer image and older data? Why does that Web Update even exist then (a check on Docker install would be good, or?)?

Thank you for your input. I will try that with the next update; for me this update procedure was really nice to do. Web update and then just replace the container with the new image.

The Docker image does a full update for you, so the only thing you need to do is change the version number for the image to run and recreate the container.

1 Like

Good to know, thank you! Will change my update behaviour in the future and this cannot happen anymore. I just hope the image is available soon.

1 Like

It will run the update automatically when it sees a new image has been loaded. There is no need to manually update it first.

I assume the update button is there just because it’s built from the same code as the other versions and they didn’t remove it.

See here for more info.

1 Like

btw it’s here now :slight_smile:

1 Like