Nextcloud 24.0.2 Upgrade MariaDB 10.5 => 10.6

I am going to upgrade MariaDB 10.5 to 10.6 and found this post concerning earlier problems: MariaDB 10.6: InnoDB refuses to write tables with ROW_FORMAT=COMPRESSED
Will I ran into this problem with Nextcloud 24.0.2 and/or are there other problems I do not know, yet?

there are lot of discussions about the root cause and parameter you need to apply to your MariaDB 10.6 config e.g. MariaDB 10.6.0 compressed row_format depreciation I’m too lazy to do research for you but I remember I read MariaDB folks added support for COMPRESSED format back in some versions…

Thank you. I had found this article already and some others which focussed on versions 21 and 22. It was also said, that with Nextcloud 24 the compatibility with MariaDB 10.6 would be achieved. So, I hoped that an expert could confirm this before I start an updating adventure without happy end.

Nobody there who has a working combination of Nextcloud 24 and MariaDB 10.6?

Yes. Me. You can set a config key/value in MariaDB’s server config to re-enable write support for row format ‘compressed’.

1 Like

Thank you, then I will try it, too;-)
Did you add this to etc/mysql/my.cnf:
[mysqld]
innodb-read-only-compressed=OFF

?

1 Like

Hallo @Kulturmensch

I can’t speak for @AlfredSK, but I think that’s what he meant by “re-enable write support for row format compressed”. Anyway, I do have this line in etc/mysql/my.cnf and everything is working fine. I am using Nextcloud 24.0.2 with MariaDB 10.6.

Btw. I have set up my instance mostly following these instructions, which do also include innodb-read-only-compressed=OFF in etc/mysql/my.cnf.

Exactly. And don’t forget to restart the database server to enable the new config.

Thank you for your helpful responses! I now upgraded today to MariaDB 10.6 and Nextcloud worked from the scratch without any problems. For the configuration I also used the recipe by Carsten Rieger and the Nextcloud documentation. By the way, I took this opportunity to get rid of the russian repository and changed to an other one.