Nextcloud 24.0.1 - opcache.interned_strings_buffer mit einem Wert größer als 8 auf Ihre PHP-Konfiguration anzuwenden

Warnmeldung:

Sicherheits- & Einrichtungswarnungen

Für die Sicherheit und Geschwindigkeit Ihrer Installation ist es von großer Bedeutung, dass sie richtig konfiguriert ist. Um Ihnen hierbei zu helfen werden einige automatische Tests durchgeführt. Weitere Informationen finden Sie in der verlinkten Dokumentation.

Es gibt einige Warnungen zu Ihrer Systemkonfiguration.

  • Das PHP OPcache-Modul ist nicht richtig konfiguriert. Weitere Informationen finden Sie in der Dokumentation :arrow_upper_right:.
    • Der OPcache-Zwischenspeicher für interne Zeichenfolgen ist fast voll. Um sicherzustellen, dass sich wiederholende Zeichenfolgen effektiv zwischengespeichert werden können, wird empfohlen, opcache.interned_strings_buffer mit einem Wert größer als 8 auf Ihre PHP-Konfiguration anzuwenden.

Bitte überprüfen Sie noch einmal die Installationsanleitungen :arrow_upper_right: und kontrollieren Sie das Protokoll auf mögliche Fehler oder Warnungen.

Überprüfen Sie die Sicherheit Ihrer Nextcloud mit unserem Sicherheits-Scan :arrow_upper_right:.

System Ubuntu 20.04

Überprüfung System, Istzustand:

grep -i opcache /etc/php/8.0/fpm/php.ini | grep -v ";"
[opcache]
opcache.enable=1
opcache.enable_cli=1
opcache.memory_consumption=128
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=10000
opcache.revalidate_freq=1
opcache.save_comments=1

Und nun, wie löse ich das Problem?

MfG

nc-kay

Alter Tread:

Lösung:

nichts geändert, aber

apt update
apt dist-upgrade

ein Reboot und die Empfehlung erscheint nicht mehr.

Sicherheits- & Einrichtungswarnungen

Für die Sicherheit und Geschwindigkeit Ihrer Installation ist es von großer Bedeutung, dass sie richtig konfiguriert ist. Um Ihnen hierbei zu helfen werden einige automatische Tests durchgeführt. Weitere Informationen finden Sie in der verlinkten Dokumentation.

Alle Überprüfungen bestanden.

MfG

nc-kay

1 Like

apt update
apt dist-upgrade

Die Schritte schaden natürlich nicht, bei mir hat jedoch nur der Neustart schon ausgereicht, damit die Meldung nicht mehr angezeigt wird.

Hmm, für wie lange nicht mehr angezeigt? Nun nach 7 bzw. 3 Tagen immer noch? Rein logisch würde es mich nicht wundern, wenn der Neustart zwar temporär den Cache leert, aber die Ursache damit nicht behoben ist. :thinking:

Ich habe den Wert von 8 auf 10 geändert, allerdings kommt die Meldung nach einer Weile wieder. Was ist dafür der “richtige” Wert?