Nextcloud 21 und webfinger

Habe seit dem Update auf 21 bzw. neu erstellt nach große Probleme folgende Meldungen:

  • Dein Web-Server ist nicht richtig eingerichtet um “/.well-known/webfinger” aufzulösen.
  • Dein Web-Server ist nicht richtig eingerichtet um “/.well-known/nodeinfo” aufzulösen.

card und cal habe ich schon gelöst bekommen. Leider jeder Versuch dabei scheitere ich. Vielleicht kann mir hier einer helfen. Benutze Apache2.

Danke

Selbe hier. Die Lösungen dazu sind für Nginx, leider nichts für Apache gefunden.

I do have this problem too.
I’m running nextcloud 21 on apache2 and php7.4 on Ubuntu server in a subdir /nextcloud.

In the apache .conf file from the ‘root’ site I have setup:
Redirect 301 /.well-known/carddav “/nextcloud/remote.php/dav”
Redirect 301 /.well-known/caldav “/nextcloud/remote.php/dav”
Redirect 301 /.well-known/webfinger “/nextcloud/public.php?service=webfinger”
Redirect 301 /.well-known/nodeinfo “/nextcloud/public.php?service=nodeinfo”

Is this the right setup? setting this up in htaccess in the root was not working at all.
Caldav and carddav do redirect in the right way, but webfinger and nodeinfo not.

i have the same config.

Hier dasselbe! Egal was und wo ich die Einträge setze Nextcloud weigert sich.
Caldav und Carddav funktioniert ohne Probleme.
Hast du schon eine Lösung?

Grüße
Daniel

Same issue, regardless of the nginx config changes.

Nein. Hoffe auf jemanden der es besser weiß.

same for me.

maybe we are missing something?

Nur zum Schluss in “apache2.conf” im /etc/apache2/ eintragen:

Redirect 301 /.well-known/webfinger /nextcloud/index.php/.well-known/webfinger
Redirect 301 /.well-known/nodeinfo /nextcloud/index.php/.well-known/nodeinfo

Problem ist bei mir gelöst.