🚀 Nextcloud 21 RC2 is available for testing!

Be sure to file a bug report if there isn’t one!

My talk app still shows 10.0.5 and shows no hint of an update. What sort of magic dust makes this available? My talk app shows the same error that yours did.

I’ve set the update channel to Beta, think that does it.

Same problem here. Talk now shows 10.0.5 as being no longer compatible after updating to NC 21.0.0. Talk just disappeared.

Talk 11 is out now, sorry, a bit sooner would’ve been better indeed.

No worries. As slow as the downloads are, it is available just in time. Sorry couldn’t resist. :wink:

At this point, I’d like to thank you and the hole Nextcloud team for the awesome work you do. I am using Nextcloud since the beginning and never had any major issues with it. And thanks to the forum and the documentation and many others in the wider Nextcloud community, I was always able to solve the smaller issuses I was facing :slight_smile:

1 Like

he, I can’t update my own server due to timeouts from the download server, so I feel your paint. By now the 1GB connection really isn’t enough…

1 Like

I was able to upgrade my test server yesterday via web interface with multiple retrys. On my production server I’ll wait a few weeks anyways. So no big issue here :slight_smile:

I updated 2 NC20.0.8 installs to NC 21 RC2.
Got a lot of errors now:

  • Wrong PHP version 7.2, but it runs already for months on 7.4 (on one instance)
  • Cron job execution does not work anymore, error (and a lot of e-mail messages now)
  • “Er is een achtergrondtaak in bezig die controleert op door de gebruiker geïmporteerde SSL-certificaten. Kom later terug.” (orange color)
  • Je webserver is niet goed ingesteld om “/.well-known/webfinger” te vinden …
  • Je webserver is niet goed ingesteld om “/.well-known/nodeinfo” te vinden …
  • Je installatie heeft geen standaard telefoonregio. (that would be new to NC 21)

But in 20.0.8 (and earlier releases) there where no messages at all.
So what is now going wrong?

I think I will restore 20.0.8 for now and wait.

NC21 final is out since last monday. No need to use an RC.

Every release brings new setup checks.

For sure you can wait.

That one is not offered yet to me and our clients. But it seems 21.0.0 is installed when I did the update to the beta channel yesterday.
So I need to find out what is wrong now.

I think one of the problems is within this part of the NC21 .htaccess:

RewriteEngine on
RewriteCond %{HTTP_USER_AGENT} DavClnt
RewriteRule ^$ /remote.php/webdav/ [L,R=302]
RewriteRule .* - [env=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteRule ^.well-known/carddav /remote.php/dav/ [R=301,L]
RewriteRule ^.well-known/caldav /remote.php/dav/ [R=301,L]
RewriteRule ^remote/(.) remote.php [QSA,L]
RewriteRule ^(?:build|tests|config|lib|3rdparty|templates)/.
- [R=404,L]
RewriteRule ^.well-known/(?!acme-challenge|pki-validation) /index.php [QSA,L]
RewriteRule ^(?:.(?!well-known)|autotest|occ|issue|indie|db_|console).* - [R=404,L]

DO NOT CHANGE ANYTHING ABOVE THIS LINE

In my case nextcloud is a subdomain. https://cloud/domainname

In httpd (apache) I have:
|*if SUB=“cloud”|
Redirect 301 /.well-known/carddav https://cloud.domain.eu/remote.php/dav
Redirect 301 /.well-known/caldav https://cloud.domain.eu/remote.php/dav
Redirect 301 /.well-known/webfinger https://cloud.domain.eu/public.php?service=webfinger
|*endif|

and that worked fine without errors until NC 21

Why cron is not working anymore? Who knows?

Why is there a background job checking importerd SSL certificates? I never imported a certificate. The site has a valid SSL certificate on the server.

Previous NC 20 scored 100% security !

NC 21 was released. If you have specific problems, please create a new topic. Closing here.