Nextcloud 21.0.2 Error: Missing PDF-view for default PDFs

Hello I am just starting using nextcloud and if there is any more information I should provide let me know.

I have been trying to setup nextcloud on UNRAID with a mariadb dabase and it was working fine 21.0.1 but when I upgraded to 20.0.2 or even did a complete clean install there was some problems with the demo pdfs. I can include my own and they seem to work but I just don’t understand what to make of it.

Also when installing(fresh or upgrade) 21.0.2 I get an error on page below

and it does not redirect me to the dashboard as it did in 21.0.1 when installing. Nextcloud seems to work but just have to manually navigate to it.

Error after initial admin+nextcloud setup:

Error when opening demo-pdf:

Any input is very welcome and if you know some material that might be useful please let me know.

The Error with the missing PDF happens if you want to open a PDF with spaces or special characters in the name. I have the same Issue with new installed version.
Do you use php8?

It worked on my Tes-tmachine with Mysql and php7. Now I have MariaDB and php8…

PHP 8 is still not recommended for Nextcloud.

1 Like

Hi! I have the same issue but he can open documents through the share link, that’s weird…
I’m using php7.4 and my files have spaces in their names.

Th everybody reading this there seems to be a general error with Nextcloud 21.0.2. There is also a temporary fix when you follow the link and it worked for my setup.


Error occurs with PHP 7.4 and PHP 8.0 in the same way so it is Nextcloud 21.0.2 related

And as Mageunic mentioned a shared pdf file works as before.
But what’s new to 21.0.2 to unshare the file again let’s the contextmenu pop up anywhere on the page but not close to the three-dot-menu why? don’t know.

same problem for me too at 21.0.2 & especially in sub-folders not 1 pdf is working anymore - in the main file folder some pdfs work & others not

i have nginx 1.19.8, debian 10 latest, php 7.4.18-fpm, maria db

That’s what I read from the Github as well

The hotfix from beardhatcode in the github thread fortunately solves it. Had the same issue on three instances after updating to 21.0.2

Hotfixes aren’t working for me…Still missing PDF but it is there on the external drive.

I just disabled the PDF viewer app for now, and use the integrated PDF viewer of Firefox. This workaround even has advantages in certain situations, because it opens the pdf in a new tab and uses the whole browser window instead of the smaller overlay.


Die you see the hotfix mentioned here?

1 Like

Jup. I saw that one. Thx.

Wanted just to mention a maybe obvious but easy workaround for users who don’t want to mess around with any code. For me personally, this is not mission critical anyway, since I only use the WebGui now and then…

I have the same issue (PDF not opening in web when containing spaces in filenames) and I’m running Nextcloud 20.0.10, so it’s not only a 21.0.2 issue.

@pascalbrax did you try the mentioned hotfix?

Yes, the hotfix worked for me on 20.0.10 too.

It’s not pretty :thinking: , but this was my first step:
not Download but open with local PDF-viewer :laughing: .

can anybody tell us how to apply the described fix? I cannot find where to download the incriminated file files_pdfviewer-main.js.

You need to modify the file manually.

thanks, worked perfectly for my two affected installations.

1 Like