Nextcloud 20 Raspberry Pi 4

Good morning all, I am hoping somebody can give me a steer.

Im new…ish to Nextcloud, revisiting it after getting involved a few years ago. What I am trying to achieve is;

Installation of Nextcloud 20 on a Raspberry Pi 4 8Gb with the integrated Talk and Collabora parts. I currently have Nextcloudpi running on it but the ownyourbits image is ver 19.03. I did force the update to in the panel which went ok with just a couple of errors and now have ver 20 of Nextcloud running with external storage, remote access and letsencrypt. So far so good and that works beautifully.

BUT. On upgrading, I didn’t manage to get the integrated Talk or Collabora (Or should that be Only Office) with the integrated server.

What I am looking for advice on is how best to start from scratch and install Nextcloud 20, with the integrations that come with that, on an RPi 4.

As above I am new to this so even just the fundamental steps would be good, starting with the OS. Should this best be Debian or Raspian? Is there an image that I can put on the SD that already has everything ie Apache Php Turn Server, Document Server or are these all separate steps?

Essentially, what is the simplest way (Not because I’m lazy but rather because I’m inexperienced with any Linux distro and new to Snap and Docker) so that I can direct what I need to understand in the right direction.

Hi Baggers,

maybe nextcloudpi suits your needs. You can take a look at it here:



It almost does but has none of the integrations that NC 20 brings so no out of the box office or talk. Ive tried the Code Server for Callobora but that failed but I read that 20 integrates everything on installing hub

As far as I know CO and Only Office don’t support arm CPUs. So their’s no chance to run them on Raspberry PI at this point.

Collabora Online is also expecting a different ipadress than your NC instance. For Talk you need to install a turn server on your system.

i just discovered there’s an arm64 CODE-server available from the appstore.

Ok… Good news and bad news for anyone looking at running Nextcloud on a Raspberry Pi 4.

GOOD NEWS: Nextcloud Talk is fully functional and quite usable. I found the connection to be incredibly quick and had no issue connecting once I figured out that if you are trying to connect you need to have WebRTC enabled. I suggest using the Nextcloud Talk Android App (I haven’t tested the iOS version as I don’t use Apple)

BAD NEWS: Unfortunately I have been unable to get the Collabora CODE ARM64 server up and running on my Raspberry Pi 4 using an ARM64 of Nextcloud. I did get an instance of Collabora Online CODE Server running (briefly) on a version of Nextcloud running under an ARMhf installation but by running I mean simply it had a green check mark saying it say the server…

Installing Collabora CODE on either architecture is possible. However any installation of Collabora Online as an App through Nextcloud causes an immediate slowdown of web page loading that makes the system unusable.

The issue is discussed here at length and affects users across architectures, Operating Systems, and installation methods.

OnlyOffice does not have an ARM64 version available for their platform either.

The only other option for a document server, Office Online, is a non-starter for me as it is a Microsoft product that requires a license. I don’t support proprietary platforms such as theirs.

This is incredibly upsetting to me. My intention was not to use the Document Server to create or edit documents but as a document viewer. Having a functional document viewer is incredibly important to me. Without one any document that I want to share with someone online must be downloaded first so effectively it would be just as useful for me to email them the files rather than host an instance of Nextcloud.

As a sidenote I considered using the “Automated Conversion to PDF” as a Work Flow for all office files since there ISa PDF viewer built into Nextcloud. However that is not an option on the Nextcloud Pi 4 either because it requires a local instance of libreoffice to be installed and Libre Office is not available using the ARM or ARM64 architecture.


If using the Raspberry Pi 4 to run Nextcloud I strongly suggest using the ARM64 architecture (ARM64=ARMv8=Aarch64) over the ARM32 architecture (ARM32=ARMhf=ARMv7). I ran into problem after problem running Nextcloud on an ARM32 OS. Those problems melted away once I switched to an ARM64 OS.