Nextcloud 20.0.1, PDF Viewer not working properly

Hello everyone!
This is my first time here in this forum.
After upgrading to version 20.0.1, the PDF viewer doesn’t work properly in my Nexcloud.
When I try to open a PDF document, I receive this error:
cURL error 3: malformed (see You can see it in the picture below.

I’m not an advanced user.
I use Ubuntu 20.04.1 LTS, with a Nexcloud installation via snap.
Can anyone help me to solve this problem, please?

same problem here. I’m using nextcloud 20.01 on Linux Mint 19.3. Deactivating and activating of the app PDF-Viewer makes no difference.

It’s a important problem of the usability of the software. Older releases are working properly.

Same here with nextcloud 20.0.2.

This worked for me

1 Like

Problem still applies in Nextcloud 20.0.3
I have just upgraded my Nextcloud from 19.0.6 to 20.0.3
Unfortunately enabling pdf reading for OnlyOffice and disabling it again as mentioned above did not change the behaviour. Error Message ist still cURL error 3…
I have also tried disabling PDF Viewer v2.0.2 an enabling it again. Same Error message as above.

If I try leaving PDF Reading enabled for OnlyOffice, OnlyOffice tries to open the file but comes up with this error message eventually:
Screenshot 2020-12-13_PDFview_in_OnlyOffice

Edit 17.12.2020:
Problem still remained after Upgrade to NC 20.0.4
After comparing with a different NC Instance that did not show the problem I figured out I still had the app Office Online Integration activated in the NC-instance with the PDF-error.
Since deactivating Office Online Integration I have no error when accessing PDF-files.

1 Like