Nextcloud 19 RC2 is here - help us test it!

Where is the RC3? It’s scheduled for today

The access rules error seems to result from the cloning / ip address range, please check what you restricted to. Community Document Server + OnlyOffice is working for me on 7 instances without issue.

Hello “Nursoda”… thanks 4your reply…

In fact, everything is working properly in my production instance as well. Due to the absence of valid certificates for the cloned production instance that I used for testing (so I changed IP and system name for this test instance) I also tried adding

onlyoffice’ => array (
verify_peer_off’ => true
)

in the nextcloud config.php but still not working…

Based on what they try to do with Talk, I wouldn’t be surprised if it takes longer than expected.
What looked like a bugfix release for a while is anything but…

EDIT
Talk 9 just made it to RC1 (app update showed up). NC 19 final should be close to release…

It is here!
Tag is available. See https://github.com/nextcloud/server/releases/tag/v19.0.0RC3

We need patience, we are release addicted :wink:

RC2→RC3 worked fine on all my 7 instances except for the test instance. That test server had the “radio” app installed. After updating, I had a weird “menu like” screen, nothing usable. occ was unfunctional, so I manually moved app directories aside. When I hit “radio”, all was back to normal. So I re-moved back everything to its place except radio, deactivated radio in /settings/apps, reinstalled it – and was fine. Strange though. Had this kind of glitch with 18.x and rainloop before, and with other apps, too. What are steps to collect usable debug data in such case?

Had the same problems with the radio app when updating from NC 18.0.4 to NC 19 RC2. I deactivated the app and wait for an update for NC 19.
Otherwise, the update from 18.0.4 to NC 19 RC2-3 has so far been without problems.

They have a bug tracker: https://git.project-insanity.org/onny/nextcloud-app-radio/-/issues

1 Like

Thanks for the bug tracker heads up. But to be honest, I doubt that it’s a radio issue since I had the same thing with multiple apps and since uninstalling and reinstalling did solve the issue. So I rather posted it here.

NC 19 final has been pushed back for a week (was planned for tomorrow)…

1 Like

In the RC3 I have still the session problem. Its happen when im logging out.
When I connect via Webdav I have the error in my logs for every single file and it is filling my logs. (Ubuntu 20.04, nginx 1.18, php 7.4.6, mysql 8.0.20)

{"reqId":"WuUJuxxxxTufiODbf","level":3,"time":"2020-05-26T09:57:42+00:00","remoteAddr":"xx.xxx.xxx.xxx","user":"--","app":"PHP","method":"PROPFIND","url":"/remote.php/dav/files/username/folder/file","message":"session_start(): A session had already been started - ignoring at /var/www/nextcloud/lib/private/Session/Internal.php#209","userAgent":"WebDAVFS/3.0.0 (03008000) Darwin/19.4.0 (x86_64)","version":"19.0.0.11","id":"5ecxxxx5e"}

Interesting date :slight_smile:

Getting close, just one more day pushback…

image

Yeah, it’s frustrating. I’m really looking forward to it. But better wait and get a stable version!

1 Like

Hm, one day more isn’t that bad, is it?

RC3 is stable IMO. Up to you!

Is it really necesarry to release 3 major versions per year?
https://docs.nextcloud.com/server/stable/admin_manual/release_schedule.html

Why not? The developers show that your project is important to them. A fast update cycle also guarantees security, which is desirable for a cloud with a lot of sensitive data.

1 Like

A fast security update cycle is good for security
A fast major update cycle is good for breaking compatibility and get headaches to third app dev.

5 Likes

Finally, version 19 was released:

Thanks to all for testing :grinning:

4 Likes