Nextcloud 19.0.0 Update screwed my installation

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 18.0.2): 19.0.0
Operating system and version (eg, Ubuntu 20.04): shared hosting (just says linux)
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.43
PHP version (eg, 7.1): 7.2.30

The issue you are facing:

The update screwed up my previous installation, so I download all the files and tried to start fresh, but a fresh installation or any of the backups let me create or remove files. I can’t open the “apps” menu or “users” menu either.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Fresh install
  2. Errors

The output of your Nextcloud log in Admin > Logging:

 [no app in context] Error: Symfony\Component\Routing\Exception\RouteNotFoundException: Unable to generate a URL for the named route "photos.page.index" as such route does not exist. at <<closure>>

 0. /home/koknocqf/nube.nortradegrupo.com/lib/private/Route/Router.php line 338
    Symfony\Component\Routing\Generator\UrlGenerator->generate("photos.page.index", [], 1)
 1. /home/koknocqf/nube.nortradegrupo.com/lib/private/URLGenerator.php line 83
    OC\Route\Router->generate("photos.page.index", [])
 2. /home/koknocqf/nube.nortradegrupo.com/lib/private/NavigationManager.php line 294
    OC\URLGenerator->linkToRoute("photos.page.index")
 3. /home/koknocqf/nube.nortradegrupo.com/lib/private/NavigationManager.php line 115
    OC\NavigationManager->init()
 4. /home/koknocqf/nube.nortradegrupo.com/apps/theming/lib/ThemingDefaults.php line 183
    OC\NavigationManager->getAll("guest")
 5. /home/koknocqf/nube.nortradegrupo.com/lib/private/legacy/OC_Defaults.php line 263
    OCA\Theming\ThemingDefaults->getShortFooter()
 6. /home/koknocqf/nube.nortradegrupo.com/lib/public/Defaults.php line 169
    OC_Defaults->getLongFooter()
 7. /home/koknocqf/nube.nortradegrupo.com/core/templates/layout.guest.php line 55
    OCP\Defaults->getLongFooter()
 8. /home/koknocqf/nube.nortradegrupo.com/lib/private/Template/Base.php line 178
    include("/home/koknocqf/ ... p")
 9. /home/koknocqf/nube.nortradegrupo.com/lib/private/Template/Base.php line 150
    OC\Template\Base->load("/home/koknocqf/ ... p", null)
10. /home/koknocqf/nube.nortradegrupo.com/lib/private/legacy/OC_Template.php line 182
    OC\Template\Base->fetchPage(null)
11. /home/koknocqf/nube.nortradegrupo.com/lib/private/legacy/OC_Template.php line 213
    OC_Template->fetchPage(null)
12. /home/koknocqf/nube.nortradegrupo.com/lib/private/Template/Base.php line 132
    OC_Template->fetchPage()
13. /home/koknocqf/nube.nortradegrupo.com/lib/private/legacy/OC_Template.php line 301
    OC\Template\Base->printPage()
14. /home/koknocqf/nube.nortradegrupo.com/remote.php line 84
    OC_Template::printErrorPage("App not installed: ", "", 0)
15. /home/koknocqf/nube.nortradegrupo.com/remote.php line 169
    handleException(RemoteException {})

MOVE /remote.php/dav/files/1tnrg/Nextcloud%20Manual.pdf
from 46.6.12.47 by 1tnrg at 2020-06-11T16:14:51+00:00


[core] Warning: Login failed: 'xoi7u' (Remote IP: '46.6.12.47')

PROPFIND /remote.php/webdav/
from 46.6.12.47 at 2020-06-11T16:11:46+00:00

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => '****',
  'passwordsalt' => '*****',
  'secret' => '*****',
  'trusted_domains' => 
  array (
    0 => 'nube.nortradegrupo.com',
  ),
  'datadirectory' => '/home/koknocqf/nextclouddata',
  'dbtype' => 'mysql',
  'version' => '19.0.0.12',
  'overwrite.cli.url' => 'https://nube.nortradegrupo.com',
  'dbname' => '*****',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => '*****',
  'dbpassword' => '*****',
  'installed' => true,
);

The output of your Apache/nginx/system log in /var/log/____:

it's a shared server. I don't have access to /var/

Anyone? please?

I am a bit confused, you say both that its a new installation and an upgrade, so what is it?

It seems like nextcloud it trying to open an app that does not exist.

Also, can you list all the subdirectories in the apps folder and the output of this sql query select * from oc_appconfig where configkey="enabled" ;?

It should look like

mysql> select * from oc_appconfig where configkey="enabled";
+---------------------------+-----------+-------------+
| appid                     | configkey | configvalue |
+---------------------------+-----------+-------------+
| accessibility             | enabled   | no          |
| activity                  | enabled   | no          |
| admin_audit               | enabled   | yes         |
| admin_notifications       | enabled   | no          |
| bookmarks                 | enabled   | yes         |
| bruteforcesettings        | enabled   | no          |
| calendar                  | enabled   | yes         |

`

Sorry, I wasn’t very clear. After upgrading the desktop client stopped working and I couldn’t upload folders anymore. I tried going back to a previous backup, but I was still encountering errors, so I did a fresh install, and it still doesn’t seem to work properly.

This doesn’t make it any clearer.

You upgraded the desktop client, and after that didn’t work you used a backup of the client or the server?

And also with the Fresh install, was it on the client or the server?
Are you currently using the old Installation, the Fresh one, or a Backup?

Can you try to disable the Photos app with: update oc_appconfig set configvalue="no" WHERE appid="photos" AND configkey="enabled";

After that, please go to the settings page (settings/admin/overview) and see if there are any errors regarding wrong files

I upgraded the server by following the instructions in the settings, and the desktop client stopped synchronizing. I tried going back to a previous version of what I had installed on the server, but it didn’t seem to work as expected either. After trying a number of backups, I gave up, and installed it from scratch. I don’t know if this has anything to do with the server, as I’m using a hosting service, but they say this is a problem with nextcloud itself.
I’ve disabled the app “photos” as you suggested, and the log doesn’t show any new errors. I still can’t delete the files that come by default (Nextcloud intro.mp4 and Nextcloud Manual.pdf), they still show but are corrupted. Also the “apps” and “users” section won’t load, all I get is a blank page. The desktop client isn’t synchronizing either, and if I try to force it to sync, it crashes (see image). I’ve changed the permissions of the folder to 777 in case there was something wrong with them. I don’t what else to do. I’m using cPanel, if that is any help.
Thank very much for taking the time to look into this
Annotation 2020-06-16 121755

anyone? :grinning: :grinning: :grinning:

Maybe you could try to see if the desktop client log contains usefull hints: https://docs.nextcloud.com/desktop/2.6/troubleshooting.html