Nextcloud 18 onlyofffice error

Hi there.

I recently upgrade my nextcloud server to the latest version, with the hope that I could have an office to use online. But when I try to activate onlyoffice app, I get this error:

[onlyoffice] Error: HealthcheckRequest on check error: Client error: GET https://nextcloud.server.com/index.php/apps/documentserver_community/healthcheck resulted in a 404 Not Found response:

404 Not Found

Not Found (truncated...)

PUT /index.php/apps/onlyoffice/ajax/settings/address
from xxx.xxx.xxx.xxx by gotzon at 2020-03-23T19:20:19+01:00

I got the Community Document Server and Onlyoffice apps installed as the install manual says. Any clues??

Thanks

No Ideas? I am really lost with this.

Have you seen this?

Thanks henry, I tried adding the new lines at my config.php, but no luck, still having the same error.

Thank you again

Hello,
Did you finally find ?
What is the URL of your nextcloud :
https://mysite/nextcloud
or
https://mysite ?

Hello,
my nextcloud URL is:
https://my.site.com

This is the line automatically added by the installation in the onlyoffice app config:
https://my.site.com/index.php/apps/documentserver_community/

I had problems because Onlyoffice does not seem to accept when nextcloud is in a subdirectory of nginx but there it is good.
In my installation, the config is : https://mysite/apps/documentserver_community/
but i dont think it’s matter

I got it working by loading the onlyoffice docker separately.
For me it was a DNS issues. Docker couldn’t find a dns entry because it only uses google dns servers by default.
I added my internal DNS servers to /etc/docker/daemon.json like this:
"dns: ["1.1.1.1","2.2.2.2"]"