Nextcloud 18 "Hub" OnlyOffice editor fails to load on fresh installation due to mixed content error

Today I deployed the latest 18.0.0 Nextcloud via docker-compose as a brand new instance, using Traefik as the reverse proxy and TLS certificate manager. Installation went smoothly and everything seems to be working as expected. However, the OnlyOffice editor is failing to load due to the following client browser console error:

Blocked loading mixed active content “http://example.com/apps/documentserver_community/web-apps/apps/api/documents/api.js”
...

I encountered the same situation in Collabora recently and solved it by configuring Collabora to (1) disable TLS and (2) terminate TLS. This allowed me to enter the https:// URL in the Collabora app settings.

How do I configure OnlyOffice in a similar way? Entering an https:// address in the OnlyOffice settings of the admin panel is not fixing the problem.

This was a typo in my config/config.php file. You need the following lines:

...
'overwrite.cli.url' => 'https://cloud.example.com',
'overwriteprotocol' => 'https',
...

1 Like