Nextcloud 15 Opcache


#1

For reason beyond my current understanding, I am not able to install php-opcache.
Centos 7, Remi Repo, Apache 2.4, php-7.2.15… Each time I enabled php-opcache, apache fails to start.
So I’ve opted to use Redis and APCu instead. Why does it still complain about opcache? Does Nextcloud require the use of 3 different/concurrent caching systems?

If use of Redis and APCu is enabled, do Nextcloud still need opcache?
Where do I go from here?

Thanks


#2

You may notice, that OPcache and memory caches like Redis are two different things, thats why Nextcloud still complains about a missing opcache. If performance is good enough for you, you may ignore this - its just a warning.

Details:
memory cache like Redis hold often accessed data in memory to improve access time.
Opcache is for keeping precompiled version of the php scripts of nextcloud to improve execution performance on server side.


#3

See also here for more information:
https://docs.nextcloud.com/server/stable/admin_manual/configuration_server/caching_configuration.html


#4

Yes, thanks for your reply. I’ve seen and followed the document for installation.
I’m using both APCu and redis settings.
Any ideas on why the remi distribution of the php 7.2 opcache module causes apache to seg fault and not start up?

By the way, I have to use the remi distribution because native CentOS version of PHP is 5.6.
So if I want to instead use PHP 7.2 then I must use a different PHP repository.


#5

Thanks for your reply…

Currently I am not heavily using NextCloud, but I will be working on a project in the near future.

The responsiveness of my NextCloud install currently is some-what fast; However that is probably due to the redis and memcache settings along with the fact that I temporarily increasing the allocated resources from my VPS provider (more cost). The VPS is currently allocated 2 VCPUs with 2 GB RAM. I would like to be able to scale it back down to 1 VCPU and 1 GB RAM.

That being said, are there others out there having this issue with not being able to have Apache use PHP-Opcache on CentOS7 using the Remi PHP repository?


#6

Thanks all…

I completely reinstalled PHP using the remi rpm package. This time, i selectively installed each PHP module instead of doing the “yum install php72-php* --skip-broken”

I now works as it should. Whoo-Hoo!!! :joy::joy: