Nextcloud 14 stops working after Fedora 28 upgrade

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2):
Operating system and version (eg, Ubuntu 17.04): Fedora 28
Apache or nginx version (eg, Apache 2.4.25): nginx 1.12.1-8
PHP version (eg, 7.1): 7.2.12-1

The issue you are facing:
After upgrading Fedora from 27 to 28 I can no longer login. I am always returned to the login form with the url: /login?redirect_url=/apps/files/

Is this the first time you’ve seen this error? (Y/N): N
The unexplained redirect back to login I’ve seen during the setup stage several months ago. I ended up removing all the install files and re-installing nextcloud to get it working.

Steps to replicate it:

  1. Installed Nextcloud 14.0.3 on Fedora 27 from source package.
  2. Upgraded Fedora 27 to 28
  3. Tried to login

The output of your Nextcloud log in Admin > Logging:

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

The output of your Apache/nginx/system log in /var/log/____: Nothing is logged when I try to login or just load the login page.

What I’ve tried so far;

  • Upgrade nextcloud from 14.0.3 to using the updater.phar.
  • Turn maintenance mode on/off
  • Set loglevel to 0 in nextcloud config.php
  • run occ maintenance:repair
  • Move my datadirectory from the old NFS share that was working to a CIFS share which is mounted using the nginx user/group. Same user/group as php-fpm and nginx are using.
  • Nothing is logged to the browser developer console when I login. I get a 303 status from the POST request.
  • Set selinux to permissive.
  • Checked oc_bruteforce_attempts, it was empty.
  • Disabled in config.php
  • Checked php-fpm log, nothing is logged during failed login attempt.
  • Tried logging in both as admin and as another user. Same issue.
  • Cleared all cookies and data for nextcloud in my browser.

Noteworthy is that Fedora 28 switched from php 7.1 to php 7.2. I’m not allowed to install 3rd party repos to downgrade back to 7.1.

Did you have a theme set up in the previous version of NC?

No, default theme. Only thing I’ve done is install apps. Here is my apps listing.

Do you have different php.ini for php7.1/php7.2? If so could you diff them? When u change to the user php is running can you create a file in

@kesselb thank you! Pointing me to session.save_path showed me that it was group owned by apache and php-fpm was running as nginx. So I just did chgrp nginx on /var/lib/php/session and now I can login again.