Nextcloud 14 flakey (tried upgrade and fresh) Apps page blank with "An error occured during the request. Unable to proceed."

Nextcloud version (eg, 12.0.2): 14
Operating system and version (eg, Ubuntu 17.04): Linux (kernel 3.10.0-714.10.2.lve1.4.74.el7.x86_64)
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.34
PHP version (eg, 7.1): 7.2.10
PHP info: https://intothegarbagechuteflyboy.net/phpinfo.php

The issue you are facing:

Tried upgrading to 14 from 13.0.5 however it resulted in many errors. The initial interface said the upgrade had resulted in an error however upon refreshing the page and logging in, it had indeed upgraded to 14. The Calendar and Contacts had been disabled and it seems like the entire installation had reset. Trying to do most things resulted in many errors. As 13.0.5 was a mostly fresh install anyway, I decided to erase everything and start with a fresh install of NC14. This was installed via Softaculous (cPanel). The installation appeared to go fine and I was able to log in.
The first thing I noticed was that the CSS didn’t load and I had to refresh the page several times before it would display correctly. Even so, some icons were still missing. The profile picture on the upper right frequently fails to load and often times clicking on menu items does nothing (the page fails to load).
I navigated to the settings and noted a number of issues but nothing that should have been a deal breaker. "Your web server is not yet properly set up to allow file synchronisation because the WebDAV interface seems to be broken." was the only actual red error.
Occasionally I clicking a link or refreshing a page results in a 500 Server Error. I also am now more often than not getting errors showing up under Security and Setup Warnings like this:


even though initially, it was correctly showing up the error and warnings. Occasionally it will load ok.

I have looked in the log and the only errors that came up was due to the intl module not being enabled and two imagik modules being loaded (due to second php.ini file which I removed).

The biggest issue at the moment is that I cannot access the apps page. It loads the menu on the left and that’s it with the error "An error occured during the request. Unable to proceed." showing at the top briefly.


The error.log and nextcloud.log files do not show any errors related to this and I cannot access the Logging page as it just sits with the circle spinner and never actually loads.

The only other changes I have made was changes to the /settings/Controller/CheckSetupController.php file suggested here: https://github.com/nextcloud/server/issues/11088

Output of config.php file in /path/to/nextcloud:

<?php
$CONFIG = array (
  'instanceid' => '▓▓▓▓▓▓▓▓▓▓▓▓▓',
  'passwordsalt' => '▓▓▓▓▓▓▓▓▓▓▓▓▓',
  'secret' => '▓▓▓▓▓▓▓▓▓▓▓▓▓',
  'trusted_domains' => 
  array (
    0 => 'intothegarbagechuteflyboy.net',
  ),
  'datadirectory' => '/home/intothegarbage/nextclouddata',
  'dbtype' => 'mysql',
  'version' => '14.0.0.19',
  'overwrite.cli.url' => 'https://intothegarbagechuteflyboy.net/nextcloud',
  'dbname' => '▓▓▓▓▓▓▓▓▓▓▓▓▓',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => '▓▓▓▓▓▓▓▓▓▓▓▓▓',
  'dbpassword' => '▓▓▓▓▓▓▓▓▓▓▓▓▓',
  'installed' => true,
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'ssl',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_from_address' => '▓▓▓▓▓▓▓▓▓▓▓▓▓',
  'mail_domain' => '▓▓▓▓▓▓▓▓▓▓▓▓▓',
  'mail_smtpauth' => 1,
  'mail_smtphost' => '▓▓▓▓▓▓▓▓▓▓▓▓▓',
  'mail_smtpport' => '465',
  'mail_smtpname' => '▓▓▓▓▓▓▓▓▓▓▓▓▓',
  'mail_smtppassword' => '▓▓▓▓▓▓▓▓▓▓▓▓▓',
  'memcache.local' => '\OC\Memcache\APCu',
);

Have opened issue here: https://github.com/nextcloud/server/issues/11300