Nextcloud 13 & Onlyoffice

I can’t seem to get Onlyoffice to work with Nextcloud 13. I have two sub-domains and two machines. Both are SSL enabled and reachable from the Internet.
When I input the address for the Onlyoffice server in the settings panel Nextcloud shows it is connected. When I try to open a file using Onlyoffice I get this error in Chrome:
“Requests to the server have been blocked by an extension.” If I try the same thing in Firefox all I get is a blank page. Looking at the logs I have:

“PHP file_get_contents( failed to open stream: Connection refused at /var/www/html/nextcloud/apps/onlyoffice/lib/documentservice.php#351”
(I believe this error happened when I tried to change the address to an IP address rather than the DNS address)


“onlyoffice CommandRequest on check error: Bad Request or timeout error”

Does this indicate a problem the the Onlyoffice app?

I have the same setup, and see the same issue, however my onlyoffice app settings page never shows successful connection.

In my log i see:

Error onlyoffice CommandRequest on check error: Bad Request or timeout error 2018-03-02T12:36:46-0500
Error PHP file_get_contents(https://myservername/ConvertService.ashx): failed to open stream: HTTP request failed! HTTP/1.1 504 Gateway Time-out at /var/www/html/nextcloud/apps/onlyoffice/lib/documentservice.php#351 2018-03-02T12:36:46-0500

I see I’m not the only one. I have finally given up after many wasted hours trying to get this to work properly.

I can’t even get the basic setting page to save, it just keeps spinning with those errors showing up in the log. Did you get past this step at least?

If i use the an internal ip address with http, i see in the logs it looks for /coauthoring/CommandService.ashx and gets a 404 not found. If i use the https internal ip address, it looks for /ConvertService.ashx and gets a 504 timeout.

Of course neither works

I was attempting this with an apache proxy server, then two machines behind it (a nextcloud on ubuntu 16.04 and a document server on ubuntu 16.04). I could set the proxy up to work correctly and reach both sites with ssl (letsencrypt). I was able to set the onlyoffice module in nextcloud to talk to the documentserver and it showed a good connection.

They never did, however, actually communicate.
On a side note, I did get it to work by taking both servers and putting them directly under a router (we are lucky to have multiple unused ip addresses). This actually worked but I soon found that modifying a file did NOT show a version change in Nextcloud nor even an activity.

IMHO this is not ready for prime time. Maybe someday but not yet.

1 Like

Please let me know if you figure this out… I really want it to work

Did you ever figure this out?

After lots of hours i made it work with the next setip/config:

My setup:

Border server: Ubuntu 16, shorewall as firewall.
Nextoclud server: virtualized Ubuntu 16 via virtualbox (bridged net adapter) in a second internal server.
Onlyoffice server: virtualized Ubuntu 16 via virtualbox (bridged too) in the same server w/NC

Both setups HTTPS with let’s encrypy certificates.
Nextcloud running against NGINX/PHP7-fpm
Registered dedicated domain to all the stuff. One for the nexcloud setup, one for the onlyoffice setup (as subdomain). IE and

To make all thing go… uses temp rules in my firewall to get the certificates (redirecting ports 80 and 443 to the host in turns to validate the certs).

I need not to loose access to the border webserver, so, i use NGINX on it and create a stream to direct pass 443 port to the NC server and 4430 port to OO server. So, the stream is setted up from 4430 external port to 443 port of the onlyoffice container. points port 443 to my nc container internal ip port 443 points port 4430 to my OO container internal ip port 443

In NC, the config of the OO estension is:

The ‘hosts’ file in both setups (NC y OO) point one to another with internal ips.

An voilá! have NC with OO behind my firewall and tunneled via NGINX in HTTPS mode.

Hope this info helps.