Nextcloud 13.0.6 in stable does not upgrade to 14

Nextcloud version: 13.0.6
Operating system and version: Debian 9.5
Apache version: 2.4.25
PHP version: 7.2

The issue you are facing:
The web settings page tells me version 13.0.6 is stable. My other stable nextcloud instance reported version 14 and upgraded flawless.

Is this the first time you’ve seen this error? Yes

Steps to replicate it:

Open the nextcloud settings page

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

  'default_language' => 'de',
  'theme' => '',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => 'nextcloud_daec',
  'dbhost' => 'localhost',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'nextcloud',
  'dbpassword' => 'xxxxxxxx',
  'logtimezone' => 'Europe/Berlin',
  'installed' => true,
  'maintenance' => false,
  'loglevel' => 2,

That’s the same for every update:

So you have to wait for the next update wave and check again. Your second server will probably be within one of the next waves then. If you want the update instantly, you have to perform a manual update.


How long will this take, now it’s already a week past and still no update available on my server.

I think they hold the process because of several bugs.
One was breaking bad :
If you re user name have a space in the name you won’t be able to use the file web gui.

They fixed it but i think a 14.0.1 will be release soon.

I have 4 servers and noone has seen the 14.0.0 stable update


If you need to update soon and are not affected by the username space bug, revert to beta, do the update, and change to stable again. This worked for me.