Nextcloud 11 : Uploading big file


I’m trying for few days to upload a very big file into my nextcloud server through the Web UI without any success.

I’ve set up all of the requirements from the nextcloud configuration regarding big files on that link ;

, I’ve added a redis server and i’m using Php7.0 fpm. My server is under ubuntu server 16.10 with Apache as proxy.

Every time the upload fails with that error :

OCA\DAV\Connector\Sabre\Exception\FileLocked: HTTP/1.1 423 “XXXX/XXXXX/XXXX.rar” is locked

The size of my file is 45G.

I’d like to precise that the upload is going until the end, then I have a the above error and the file is removed from my server. I also checked into the temp directory upload from my php configuration and nothing.

Does anyone have already encountered that issue?

Thanks for your help

Well, 45 GB ist not just big, it’s HUGE!
I had some problems with big files, too. But they were just 1.5 GB. With some patience they arrived on the server.
To unlock a file, have a look to: File is locked - how to unlock

1 Like

NC is normally tested for Apache + mod_php. There have been some reports with issues on php-fpm setups on apache. These were primarily setups with administration panels, so often it was hard to tell if the errors were due to the fpm itself or just due to the special configuration of this administration tools. If you can and have mod_php installed, you might check if it works with that as well, so you can focus on php-fpm specific settings.


Sorry for the belated response.

Anyway thanks for your replies, I know it’s huge file but I should be able to upload that kind of file event if it’s take time.
The issue about my file locked is it’s not here anymore, after finishing the upload my file is deleted.
The log says that the file was locked, but when i looked into the temp directory there is nothing whereas I could see it during the upload.

As you suggest @tflidd i’ll try without php-fpm and I’ll keep you aware but I don’t know when I will find some time to do that so It could take time :slight_smile: