Nextcloud 10.0 - internal server error 500 (Apache) regarding - LimitInternalRecursion, web interface inaccessible

Nextcloud 10.0, ubuntu 16.04

In an effort to get working the android owncloud-news app… I blog post suggested to run the following command

sudo -u www-data php /var/www/nextcloud/occ config:app:set news installed_version --value=“9.0.3”

The command completed successfully and then my web interface forced me to UPGRADE. The upgrade completed successfully and my Desktop Client came back on line… all seemed in order.

Problem now:
When I went to access the web interface I received an http internal server error, i.e. my web interface is not accessible. I looked into my apache logs and found this entry:

[Mon Sep 26 23:48:23.923915 2016] [core:error] [pid 1192] [client 10.10.1.41:46210] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace.

this is my Apache conf file:

     ServerAdmin waynegregori@gmail.com
     ServerName cloud.gregorigroup.com
     DocumentRoot /var/www/nextcloud

     <Directory /var/www/nextcloud/>
       Options +FollowSymlinks
       AllowOverride All

      <IfModule mod_dav.c>
        Dav off
      </IfModule>

       SetEnv HOME /var/www/nextcloud
       SetEnv HTTP_HOME /var/www/nextcloud
     </Directory>

     <IfModule mod_headers.c>
          Header always set Strict-Transport-Security "max-age=15768000; preload"
     </IfModule>

     SSLEngine on
     SSLCertificateFile /etc/letsencrypt/live/cloud.gregorigroup.com/fullchain.pem
     SSLCertificateKeyFile /etc/letsencrypt/live/cloud.gregorigroup.com/privkey.pem

   </VirtualHost>
</IfModule>

Any ideas?
Thanks a bunch,
Wayne

Fixed it… restored my /nextcloud directory from prior day…

The “supposed” fix for the Android Newsreader clobbered the installation… best as I can tell it changed the .htaccess file…
Thanks for all the great work. You guys are brilliant!
Wayne

I wanted to thank you. Your reply pointed me in the right direction. I just upgraded from 9.0.50 to 10.0.3 and had the same thing happen. comparing the 2 .htaccess files I found that the new file had added some rewrite statements at the bottom.

The offending line for me was: RewriteBase’ => ‘/nextcloud’

Since my nextcloud directory is at /var/www/nextcloud and not /var/www/html/nextcloud
this line completely killed my site. Removing nextcloud directory and leaving it at ‘/’ fixed my problem and allowed me to leave the site upgraded.

Glad the message string served you. And thanks for posting the
additional info.

Wayne