Nextant: indexing not running for some users

I’m trying to make full-text search work on a fresh Nextcloud installation and the problem I’m facing is that when I run indexing with
sudo -u www-data ./occ nextant:index
command, some of my AD users are missing from the output and thus the search doesn’t work for them. The same users are listed in Nextcloud web-interface under Users. I’ve tried to change LDAP\AD integration configuration editing LDAP queries and it’s changed the output, but I still can’t get all my users to be listed in indexing results. My LDAP configuration shows that there are >1000 users found but indexing results never show more than 1000 users. Is there any limitation to the number of users/folders solr can process? Or the problem is in LDAP config? Any suggestions?

I followed “Setup your local Solr as a Service” tutorial (

Nextcloud version 12.0.3
Operating system Ubuntu 16.04
PHP 7.0.22

should not have any limitation, however I do not support nextant anymore, but I am currently rewriting the whole app:

A first alpha release is to be expected before the end of the month.

Thanks for your reply. Still can’t figure out what’s wrong with my config. When I run sudo -u www-data ./occ nextant:index not all domain users get indexed, but if I run sudo -u www-data ./occ nextant:index --user1, indexing run for user1 gust fine even he is missing from ./occ nextant:index.