Nextant 0.10.4 - last rc

What is nextant !?


  • Upload/creating a .noindex file in a folder will prevent nextant to index its content (and subdirectories).
  • –background will force the scan on next tick of the cron .
  • Live Index can use database instead of Semaphore.
  • improvement on search scoring.
  • bugfixes.

This is the last release candidate and you should index your files when updating to 0.10.4:

 ./occ nextant:clear
 ./occ nextant:check --fix
 ./occ nextant:index
1 Like

Dear Cult,
the index process is going too slow and is getting killed,
are threre any specific settings for soc’s i have orangepi+2e with armbian Xenial server.
Please guide

@earth : was it working better before that update ? which version were you using before updating ?

Last version which I used was 0.6.3, then I uninstall it after you announce it was not perfect for soc.
Now I tried as in 0.10.3 rc changeling stated for socs.
So don’t know much about what worked perfectly for me.
But niw it is getting killed.

ok, I ordered few Pi3 that I will receive I guess for christmas; only then I will be able to write documentation on how to set up Solr on that kind of low-end equipment.

Until then, we can have a look to your issue, do you have any logs from Solr when it crashes ? I know the Pi2 got 1Go of RAM, how many RAM do you assign to Solr ? is your Swap full ?

sorry Dear,
yesterday i uninstalled it,
but if u want i am ready to install it again and provide you logs, needed by you.


just installed Nextant on my Nextcloud for the first time … So far - looks very well :slight_smile:

But when I want to open e.g. a PDF I get an error message in the PDF viewer:

PDF.js v1.1.469 (build: f06aa6a)
Message: Missing PDF "".

The problem is - if you starting the search in a subfolder and the file is located in a different folder, the URL is not correct. The file above is located in /dokumente/Zeitungsartikel and I started the search in the folder /1sortieren …

Have I missed some configuration!?!


Okay … perhaps the “%2” in the URL is a problem too … :confused:

@guddl i’ll have a look, ty for report. Please use the github tracker next time :slight_smile:

@earth it’s up to you.

@guddl: bug is fixed, thanks for report.
I am still curious: are you using nc10 or nc11 ?

Thanks :slight_smile: I’m using nc10 on my production cloud :smiley: