Next cloud shared links lost

Dear Experts,
via our NextCloud I stored and shared .jpg/.png pictures with my colleagues. ( I after the upload I used the “New share link” and “Rename link” to avoid cryptical links). It worked perfect. Later, I renamed my directory to another name (via NextCloud sync app for macOS). After that all shared links disappeared. When I try to re-create them, I get the error that the link name already exists. Using another link name would mean to update lot of documents where I already used it. Please help how can I restore my shared links? Or at least how to unblock the link names which point now to nowhere so I can re-use them again.
Best regards

Sounds like a bug. Nothing on the logs of something failing when you renamed the share? Do you use a current version? In this case, this could be a bug (with the version, someone can try to reproduce this).

I tried to reproduce with another folder but without success. It seems that renaming was just my last activity shortly before I realised missing links. Could it be, there is some timeout setting for shared links? In that case my links would automatically disappear after approx. 3 months. But then, the LINK name should be available for re-use again, right? Any Idea, how can I free up the shared names I originally used ? How can I avoid temporary shared links at all ?

If you have database access you can look in the tables oc_shares and oc_shares_external (The oc part can be something else depending on your install). This will give you an overview of all shares.

In theory you could delete the relevant rows directly in the database. I have done this before, but manipulating the database is not recommended. It might have some other adverse effects.

/!\ This is a hack, AFAIK not officially supported and could render your server unusable /!\
Always backup your data and in this case especially the database.

EDIT: Just to make sure, it isn’t coincidentally the following issue?

I don’t think it is related to the issue listed above as there are other folders with shared files not affected by this issue. Thanks for the table names. I will check.