Next Cloud keeps synching, even when it has completed the synchronization succesfully

I have the NextCloud desktop client installed on my Archlinux Machine. It has installed fine without any issue. My NextCloud server is on latest version and it has an AWS S3 external storage connected to it. The S3 external storage is where I have all my NextCloud files.

There are two things that worry me:

  1. After the client has completed the synchronization successfully (because the white on green background approval icon appears after finishing synching, and I don’t get any errors or warnings), it waits almost a minute, and then starts the synchronization of the External Storage folder once again from the beginning. What I understand is that if it finished synching correctly and I haven’t rebooted my machine or changed the local folder, it shouldn’t start the hole synchronization again.
  2. When I create a new file in my local folder on my computer, it has to wait for the NextCloud client to do a hole sweeping of the local folder, while synching, to find the new file and upload it. What I understand is that it shouldn’t be that way, the linux client should detect the new file and upload it right away without having to wait for a hole synch process from scratch.

Please correct me if maybe I’m the one wrong, and maybe I don’t understand exactly how the client and the sync process work, or, else, help me with a solution.

I think I have the same issue (Nextcloud constantly sync’ing for no obvious reason) but my files are stored locally on the server.
Any hint as to what could cause this?

Also, the client UI popped the following message up:
“This sync would reset the files to an earlier time in the sync folder ‘Docs’.
This might be because a backup was restored on the server.
Continuing the sync as normal will cause all your files to be overwritten by an older file in an earlier state. Do you want to keep your local most recent files as conflict files?”


Well, my problem seems to be more simple. Everything is synching right. But the external storage folder always starts synching again, around 30 seconds after it has finished synching succesfully, and the green check has appeared. But I don’t have any problems with the files reset to an earlier time.

Sorry for the late update on this. Finally I found out what my problem was. I had my AWS S3 External Storage configured in “Check for Changes” as “Once Every Direct Access”, so I changed it to “Never”, and the Synchronization of the S3 started working perfectly.

This happened because I misunderstood that if I configured it as “Never” it would never sync automatically, but what it refers to is that it will never check for changes outside the Nextcloud client or web access.

1 Like

Hi @nielsmartinez, I recently tried to sync my Google Drive folder to Nextcloud using the desktop app. I faced the same irritating issue of the app syncing continuously. The way I solved it: I disabled the “sync hidden files” option from the settings. This way, it still syncs the folder if there are any changes, but will not sync in between. Hope this helps.
Here are couple of screenshots of what I mean.

I have seen constant “checking for changes” scans for years and I don’t think it is only caused by external storages.
Mine searches through all folders, even sub-directories of ignored folders. I’m not sure why it has to constantly do this and why is so slow doing it. I wish it would show the full path so I knew where it was looking too.

It’s a bit of an old thread, but I think I am having the same issue. This only started to occur after I installed the latest NC client and enabled the “support for virtual files” feature.

Disabling the “sync hidden files” did not change anything for me. Setting the “Check for Changes” to never for my external storage did not change anything either it seems. It just keeps scanning and scanning away. Causing my load average to eventually go to 10+ on my Nextcloud instance and rendering the UI useless.

I might create a new issue for this, but just wanted to let you know.

1 Like