Nexcloudpi failed to start dhcpcd on all interfaces

This morning I can’t access nextcloud over the internet, yet I haven’t changed anything.
when I start my raspberrypi connected to my tv I can read “failed to start dhcpcd on all interfaces”

I have the latest version of NextCloud and the latest version of nexcloudpi

Thank you for reading me.

1 Like


it seems that I also have this problem. I haven’t changed anything and now NCP doesn’t work anymore since this morning.

A monitor connected to HDMI shows:
FAILED: Failed to start dhcpcd on all interfaces

I can’t reach NCP anymore, neither SSH nor via browser and also not via the internal IP.

What can I do? Unfortunately I am not very experienced…

1 Like

Hello Sputnik
Have you found a solution?

Unfortunately not yet…
I am now trying to restore an old image of my SD card.

I have the same Problem. My Workaround is to start the dhcpcd Service manually.

  • Login local at the rapi with username pi and your password
  • start the dhcpcd service with the command " sudo dhcpcd"

it works until the next restart. I hope the Problem will be fixed soon.



I had the same problem.
Thanks for your workaround, it works. :slight_smile:

After that, my nextcloud still wasn’t accessible from the outside… I updated everything and saved my no-ip data in the nextcloudpi panel again and everything went well now. :slight_smile:

Problem solved
Thank you nextcloudpi

I also am having the same problem as you guys

1 Like

I have the same problem again.

I have the same problem, which I think may have started with a recent upgrade (I’m currently on NextCloud and NextCloudPi 1.12.7)

In my case, I need to RPi to have a static IP address, and I’ve tried to do this both by using the static ip configuration on my router and also by using the ‘nc-staticip’ on the administration, but get the same results: the dhcpcd takes too long during boot, but if i later run ‘sudo dhcpcd’, everything is fine.

I have the issues in ncp 1.13.1, and for many months previously. Has anyone found a permanent fix?

Hi everyone,

Seems like we might have found the fix for this. Some positive feedback would be great.

Looks like a bad Raspbian bug.


    sudo apt-get update
    sudo apt-get install haveged
    sudo systemctl enable haveged.service

Doesn’t work! after booting I need “sudo dhcpcd”
please, how to uninstall

I made
sudo apt-get --purge remove haveged
to uninstall

I unfortunately didn’t see the comment from @nachoparker. However, I noticed I appear to no longer have this issue on 1.15.3, without doing anything. I have not upgraded to buster yet, planning to do that now. I will report back if the issue re-surfaces.

yes, I pushed the fix to all users

Thanks nacho. I found the bug discussion. I appreciate the work on this!