Nexcloud 27 with mariaDB 11.0.2 stopped working

Hi there,

I’ve facing a new problem - I’ve never seen since 5 years of using nextcloud. I’m running nextcloud as a container using docker-compose and my mariaDB seems to be corrupt, since it is not able anymore to start. The container is in a start up loop and I’m always getting the following error

db_1   | 2023-07-11 21:15:45+02:00 [Note] [Entrypoint]: Switching to dedicated user 'mysql'
db_1   | 2023-07-11 21:15:45+02:00 [Note] [Entrypoint]: Entrypoint script for MariaDB Server 1:11.0.2+maria~ubu2204 started.
db_1   | 2023-07-11 21:15:45+02:00 [Note] [Entrypoint]: MariaDB upgrade information missing, assuming required
db_1   | 2023-07-11 21:15:45+02:00 [Note] [Entrypoint]: MariaDB upgrade (mariadb-upgrade) required, but skipped due to $MARIADB_AUTO_UPGRADE setting
db_1   | 2023-07-11 21:15:45 0 [Note] Starting MariaDB 11.0.2-MariaDB-1:11.0.2+maria~ubu2204 source revision 0005f2f06c8e1aea4915887decad67885108a929 as process 1
db_1   | 2023-07-11 21:15:45 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
db_1   | 2023-07-11 21:15:45 0 [Note] InnoDB: Number of transaction pools: 1
db_1   | 2023-07-11 21:15:45 0 [Note] InnoDB: Using crc32 + pclmulqdq instructions
db_1   | 2023-07-11 21:15:45 0 [Note] mariadbd: O_TMPFILE is not supported on /tmp (disabling future attempts)
db_1   | 2023-07-11 21:15:45 0 [Note] InnoDB: Initializing buffer pool, total size = 128.000MiB, chunk size = 2.000MiB
db_1   | 2023-07-11 21:15:45 0 [Note] InnoDB: Completed initialization of buffer pool
db_1   | 2023-07-11 21:15:45 0 [Note] InnoDB: File system buffers for log disabled (block size=512 bytes)
db_1   | 2023-07-11 21:15:45 0 [Note] InnoDB: Upgrading the change buffer
db_1   | 2023-07-11 21:15:45 0 **[ERROR] [FATAL] InnoDB: Unable to find charset-collation for 15**
db_1   | 230711 21:15:45 **[ERROR] mysqld got signal 6 ;**
db_1   | This could be because you hit a bug. It is also possible that this binary
db_1   | or one of the libraries it was linked against is corrupt, improperly built,
db_1   | or misconfigured. This error can also be caused by malfunctioning hardware.
db_1   |
db_1   | To report this bug, see
db_1   |
db_1   | We will try our best to scrape up some info that will hopefully help
db_1   | diagnose the problem, but since we have already crashed,
db_1   | something is definitely wrong and this may fail.
db_1   |
db_1   | Server version: 11.0.2-MariaDB-1:11.0.2+maria~ubu2204 source revision: 0005f2f06c8e1aea4915887decad67885108a929
db_1   | key_buffer_size=134217728
db_1   | read_buffer_size=131072
db_1   | max_used_connections=0
db_1   | max_threads=153
db_1   | thread_count=0
db_1   | It is possible that mysqld could use up to
db_1   | key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 468023 K  bytes of memory
db_1   | Hope that's ok; if not, decrease some variables in the equation.
db_1   |
db_1   | Thread pointer: 0x0
db_1   | Attempting backtrace. You can use the following information to find out
db_1   | where mysqld died. If you see no messages after this, something went
db_1   | terribly wrong...
db_1   | stack_bottom = 0x0 thread_stack 0x49000
db_1   | Printing to addr2line failed
db_1   | mariadbd(my_print_stacktrace+0x32)[0x556c3870fa62]
db_1   | mariadbd(handle_fatal_signal+0x488)[0x556c381e2e28]
db_1   | /lib/x86_64-linux-gnu/[0x7fdc73001520]
db_1   | /lib/x86_64-linux-gnu/[0x7fdc73055a7c]
db_1   | /lib/x86_64-linux-gnu/[0x7fdc73001476]
db_1   | /lib/x86_64-linux-gnu/[0x7fdc72fe77f3]
db_1   | mariadbd(+0x69753b)[0x556c37df753b]
db_1   | mariadbd(+0x6812f7)[0x556c37de12f7]
db_1   | mariadbd(+0xdf703f)[0x556c3855703f]
db_1   | mariadbd(+0xdd40f2)[0x556c385340f2]
db_1   | mariadbd(+0x6b2ebc)[0x556c37e12ebc]
db_1   | mariadbd(+0x691449)[0x556c37df1449]
db_1   | mariadbd(+0xd7aad9)[0x556c384daad9]
db_1   | mariadbd(_Z24ha_initialize_handlertonP13st_plugin_int+0x86)[0x556c381e60b6]
db_1   | mariadbd(+0x83d686)[0x556c37f9d686]
db_1   | mariadbd(_Z11plugin_initPiPPci+0x91d)[0x556c37f9e84d]
db_1   | mariadbd(+0x70bb91)[0x556c37e6bb91]
db_1   | mariadbd(_Z11mysqld_mainiPPc+0x424)[0x556c37e71324]
db_1   | /lib/x86_64-linux-gnu/[0x7fdc72fe8d90]
db_1   | /lib/x86_64-linux-gnu/[0x7fdc72fe8e40]
db_1   | mariadbd(_start+0x25)[0x556c37e65b05]
db_1   | The manual page at contains
db_1   | information that should help you find out what is causing the crash.
db_1   | Writing a core file...
db_1   | Working directory at /var/lib/mysql
db_1   | Resource Limits:
db_1   | Limit                     Soft Limit           Hard Limit           Units
db_1   | Max cpu time              unlimited            unlimited            seconds
db_1   | Max file size             unlimited            unlimited            bytes
db_1   | Max data size             unlimited            unlimited            bytes
db_1   | Max stack size            8388608              unlimited            bytes
db_1   | Max core file size        unlimited            unlimited            bytes
db_1   | Max resident set          unlimited            unlimited            bytes
db_1   | Max processes             unlimited            unlimited            processes
db_1   | Max open files            1048576              1048576              files
db_1   | Max locked memory         65536                65536                bytes
db_1   | Max address space         unlimited            unlimited            bytes
db_1   | Max file locks            unlimited            unlimited            locks
db_1   | Max pending signals       63352                63352                signals
db_1   | Max msgqueue size         819200               819200               bytes
db_1   | Max nice priority         0                    0
db_1   | Max realtime priority     0                    0
db_1   | Max realtime timeout      unlimited            unlimited            us
db_1   | Core pattern: |/usr/share/apport/apport -p%p -s%s -c%c -d%d -P%P -u%u -g%g -- %E
db_1   |
db_1   | Kernel version: Linux version 5.15.0-58-generic (buildd@lcy02-amd64-101) (gcc (Ubuntu 11.3.0-1ubuntu1~22.04) 11.3.0, GNU ld (GNU Binutils for Ubuntu) 2.38) #64-Ubuntu SMP Thu Jan 5 11:43:13 UTC 2023
db_1   |
db_1   | Fatal signal 11 while backtracing

Anyone can help me with that one? Thank you.

Ok - seems to be an issue from mariaDB 11.0.2.

I was able to start my server using my docker-compose by adjusting the version of mariadb to 10.11.3

Thanks so far and do not run automatic update scripts for mariadb :smiley:

1 Like

I had the same issue when upgrading from NC25 to 26.0.5. I edited my docker-compose file and tried

image: mariadb:11.0


image: mariadb:11

which led to the same error.

so I tried

image: mariadb:10

which worked fine (and used mariadb 10.11.4 at the time)

1 Like

In general:

1 Like

It is strange, because in another docker-image on the same server it runs fine with NC 26.0.4 and latest mariadb, which is running on 11.0.2 now

I know this is “solved” but Google took me here and most people should be using the MariaDB that is on the official requirements. I think they should see this answer.