Nexcloud 18 - Up and running, error with ocdata


I do have a local cloud running, able to login as an admin, but on the Security & setup warnings, I get the following, I quote:

"It was not possible to execute the cron job via CLI. The following technical errors have appeared:

Your data directory is invalid Ensure there is a file called “.ocdata” in the root of the data directory."


Nextcloud version:18
Operating system and version: Raspbian Buster
PHP version: 7.3.11

I moved the data from var nextcloud to my USD Sata Disk and after that the error started showing app.

1 Like

Make sure that the datadirectory parameter within your Nextcloud configuration file is pointing to the new location and that a file called “.ocdata” exists in that directory.

I get more or less the same error message after upgrading to NC18 (web upgrade).
I did not move my installation anywhere, and everything seems to be at the right place.

It was not possible to execute the cron job via CLI. The following technical errors have appeared:

La cartella dei dati non è valida Assicurati che ci sia un file ".ocdata" nella radice della cartella data.
Your data directory is not writable I permessi possono essere normalmente corretti fornendo al server web accesso in scrittura alla cartella radice. Vedi

For some funny reasons part of the error messages are in italian…

hello, same issue also for me. Data folder is a docker volume, .ocdata is existing and permissions are ok.

what else I can look?
did you solved?

Well, what i did to fix it was to go to Basic Settings, switch to Cron, then go back to overview, let the scan run and all went fine, then went back to Basic Settings and select AJAX back, then go back to Overview and let it run and that was it, it was fixed, idk if it will work for u guys but it did for me, i think its the 2nd time this has happened to me and i fixed it like this, cause i had the .ocdata file on my Nextcloud Data folder, plus the permissions and ownership was fine as well


I had this exact same problem while everything was seeming to work OK so I found your solution and it worked for me too!
Thanks. Now I just need to know what the cause is!

Worked for me as well (I used “webcron” though). Thanks for sharing!

Thanks for the info, your suggestion fixed the issue for me. Thanks

ur welcome :slight_smile:

Worked for me too. Thanks!

I recently replaced the hard-drive with the nextcloud data-directory in it to a new one, and ran rsync to replicate the data on the new drive. After testing the new setup for a week, everything was running as expected, but a similar error as on OP’s post appeared on my admin page. @javito’s solution fixed the issue in my case as well!