Newbie - struggling with initial install

,

Hi everyone,

I’ve recently installed Nextcloud using the NextcloudPi image and have successfully logged in. However, I’m finding it challenging to navigate back to the initial setup where I can specify the hard drive and create a DNS. I’ve tried following a tutorial video, but the steps are a bit unclear to me.

Should I consider switching to a Docker installation, or is the NextcloudPi method okay? While I’ve managed to create the SD image and log in, I’m struggling with the configuration. Any advice or guidance would be greatly appreciated!

Thanks in advance for your help!

If anyone could suggest the best install method for pi4 I’d appreciate it.

You can use ncp-config from the terminal or navigate to https://your-ncp-local-ip:4443 to setup and tweak your ncp installation

All current ncp documention

1 Like

Thanks for tip. To be honest I’m struggling. Does anyone have a fool proof install for Nextcloudpi - I’ve tried though I’m really struggling. The youtube videos seem quite old or not relevant for this image.

I need

Port forwarding
dns setting - duck dns or something similar
Enable - ssh

Straightforward and well presented instructions assuming little knowledge.

Sorry to here you are struggling, and afaik there is no such thing as fool proof in matters of server administration. It can be hard in the beginning.

Port forwarding is managed from your router, so it has nothing to do with NCP or NC. You need to log in to the box provided by your Internet provider.
Mine is at 192.168.1.1 and look for NAT/PAT to add the port forwards

DNS settings are also found in your router. Usually on same page but under another tab.

SSH can be enabled from ncp-web:4443

Hope that helps

Thanks for your help! I now have everything working perfectly, and I’m able to log in remotely!

I’m just struggling with adding my external 8TB hard drive. I formatted it using exFAT on a Mac with the GUID Partition Map.

I’ve enabled the app which supports external drives.

This is the message I get when I try to add it:

“No external storage configured or you don’t have permission to configure them.”

Global credentials: Global credentials can be used to authenticate with multiple external storages that have the same credentials.

There’s then a login box… I type in my login it accepts it though nothing happens.

exfat is not a linux filesystem all tho you can use it if you install exfat-fuse and exfat-utils you cannot set permissions like in linux because it simply doesn’t support it.

when you plug in the usb drive it is most likely automaticly mounted in /media/[USERNAME]/[DRIVE-NAME] where [USERNAME] is most likely pi

Nextcloud needs read/write access to this disk but under the USERNAME of your Webserver ( www-data )

You can use exfat but it needs to be mounted under the uid/gid of your webserver.
when you login ssh on pi you can check if the webserver can write to your exfat disk
go where your disk is mounted example /media/pi/HDD

cd /media/pi/HDD
sudo -u www-data touch delete.this
sudo rm delete.this

If the disk is not yet used I would suggest to format it ext4 to avoid such problems.

Have you thought about the future when the 8Tb is full.
check out LVM it allow logical volumes spanning over multiple disks.

Thanks for you help Vincent however this is a little too complicated for me. Can anyone else help?

I’m really struggling. I’ve installed NextcloudPi 4 times due to various issues. I now need to use my external drive (8TB). I’ve tried formatting it on my Mac using GPT fdisk; however, it still isn’t being recognised. Can somebody give me the steps to

  1. Format the external drive (to the correct format)

  2. Mount it in Nextcloud

  3. Allow me to use it as storage?

At this storage I have none of my data on the drive.

Thanks very much in advance.

Please stop cross posting. Stay with one topic

1 Like

Thanks - as you can see - I’m at a bit of a loss with all of this.

Thanks Vincent for your help. I’m struggling to follow you’re instructions, as I’m new to this, I’ve now got the following message during login - Your data directory is invalid.

Ensure there is a file called “.ocdata” in the root of the data directory.