New to NextCloud and need some help with external storage + local SMTP server

Hi All,

I’m new to using NextCloud Community edition and it’s really awesome!.

So I will explain my environment so it’s easier to understand why I ask;

Currently at home I’ve got a Dell server with ample storage and ram etc;

I’m running
2 domain controllers WS2022
1 Microsoft Exchange Server Enterprise WS2019
1 file server WS2022
1 VPN server using MS L2TP WS2022
1 Backup server and script scheduling server WS2022
1 CCTV server WS2022
1 Ubuntu Server for Passbolt self hosted password manager Ubuntu 2204 LTS (Not domain joined)
1 Ubuntu Server for NextCloud running 26.0.0 and Ubuntu 2204 LTS (Domain joined)
1 Ubuntu server testing OwnCloud (Domain joined)

So I’m wondering how can you make NextCloud display the user storage space. I’m not using the local storage on the Ubuntu server it’s actually running on my backup server with Windows Server 2022, it mapped using the external storage support under SMB-PHP and CIF shares.

and lastly
As I’m running an exchange server at home I cannot get the newer version of nextcloud the use my smtp details but it worked when I built the first version of 20.0.4

I spent my entire 4 day weekend building it 4 times each time I tried different things and the last build was the most perfect build and works solid!

Thanks for reading my rant, i’m pretty proud of my domain at home and it’s nothing used for business.

Perth Australia :slight_smile:

You’ll have to explain what you mean by this.

Maybe this is working for you, but every time I hear about someone using a SMB mount for Nextcloud’s data, they are having weird problems. You should use the Ubuntu server’s own storage if possible. If you really can’t then I would suggest iSCSI over SMB.

What are your receive connector settings? Presumably you get some error?

Hi Karl,

Thanks for replying :slight_smile:

So the storage space displays what’s free on the server volume drive rather than what’s my SMB share but that’s a nice to have and not a must-have.

The exchange server allows me to send local unauthenticated smtp emails with all my powershell checking scripts on my servers in my local domain but NextCloud just doesn’t like it

I think it always shows the space where either the web root or date folder is. I don’t know of a way to make it display primarily the free space of a particular external storage. Some of the external storage protocols I think would not support transmitting that info either, although SMB would.

You didn’t post the SMTP config, connector config, or the SMTP error, so I’m not sure what to suggest there. If it’s a known working unauthenticated connector, then I would probably wireshark it to see if I can figure out at what step it’s failing.


I wasn’t able to find any exchange logs so it’s not making it back to my exchange server. I used a 3rd party smtp server called smtp2go which works fine. I wondering if it’s a firewall rule on the ubuntu server?

Blocking outbound traffic? Not unless you told it to.

You can run tshark or tcpdump to capture it on the sending side.

1536 88.743872248 → SMTP 64 C: STARTTLS
1537 88.744026363 → SMTP 83 S: 220 2.0.0 SMTP server ready
1538 88.744651726 → TLSv1 571 Client Hello
1539 88.745516646 → TLSv1.2 1312 Server Hello, Certificate, Server Key Exchange, Server Hello Done

1540 88.746374104 → TLSv1.2 61 Alert (Level: Fatal, Description: Unknown CA)

1541 88.746615487 → TCP 54 59220 → 25 [FIN, ACK] Seq=558 Ack=1646 Win=64128 Len=0
1542 88.746683179 → TCP 60 25 → 59220 [ACK] Seq=1646 Ack=559 Win=16776192 Len=0
1543 88.746726004 → TCP 60 25 → 59220 [FIN, ACK] Seq=1646 Ack=559 Win=16776192 Len=0
1544 88.746742245 → TCP 54 59220 → 25 [ACK] Seq=559 Ack=1647 Win=64128 Len=0
1545 88.748771251 → TLSv1.2 767 Application Data
1546 88.848443868 → TLSv1.2 134 Application Data
1547 88.848473321 → TCP 54 443 → 42958 [ACK] Seq=14638 Ack=2692 Win=501 Len=0
1548 88.878743067 → TCP 60 42958 → 443 [ACK] Seq=2692 Ack=14638 Win=4101 Len=0
1549 88.882019275 → DNS 88 Standard query 0xbab1 AAAA *EXCHANGE NAME REMOVED FOR PRIVACY OPT
1550 88.882376462 → DNS 155 Standard query response 0xbab1 AAAA *EXCHANGE NAME REMOVED FOR PRIVACY SOA OPT
1551 88.882551694 → TCP 74 59222 → 25 [SYN] Seq=0 Win=64240 Len=0 MSS=1460 SACK_PERM=1 TSval=1507201572 TSecr=0 WS=128
1552 88.882702818 → TCP 66 25 → 59222 [SYN, ACK] Seq=0 Ack=1 Win=65535 Len=0 MSS=1460 WS=256 SACK_PERM=1
1553 88.882715315 → TCP 54 59222 → 25 [ACK] Seq=1 Ack=1 Win=64256 Len=0
1554 88.883470218 → SMTP 151 S: 220 *EXCHANGE SERVER NAME REMOVED FOR PRIVACY Microsoft ESMTP MAIL Service ready at Thu, 13 Apr 2023 10:18:24 +0800
1555 88.883490409 → TCP 54 59222 → 25 [ACK] Seq=1 Ack=98 Win=64256 Len=0
1556 88.883542584 → SMTP 77 C: EHLO []
1558 88.883848997 → SMTP 64 C: STARTTLS
1559 88.884006276 → SMTP 83 S: 220 2.0.0 SMTP server ready
1560 88.884620084 → TLSv1 571 Client Hello
1561 88.885508271 → TLSv1.2 1312 Server Hello, Certificate, Server Key Exchange, Server Hello Done

1562 88.886337681 → TLSv1.2 61 Alert (Level: Fatal, Description: Unknown CA)

1563 88.886548210 → TCP 54 59222 → 25 [FIN, ACK] Seq=558 Ack=1646 Win=64128 Len=0
1564 88.886606639 → TCP 60 25 → 59222 [ACK] Seq=1646 Ack=559 Win=16776192 Len=0
1565 88.886719932 → TCP 60 25 → 59222 [FIN, ACK] Seq=1646 Ack=559 Win=16776192 Len=0
1566 88.886735941 → TCP 54 59222 → 25 [ACK] Seq=559 Ack=1647 Win=64128 Len=0

That one that said “Unknown CA” is very interesting because the exchange server is using an R3 wildcard certificate and my NextCloud server is using a named certificate BUT nextcloud had the same certificate as before the upgrades to version 26.0.0 so i’m wondering why it’s a problem now?

I think it’s the other way around. It sounds like maybe Nextcloud is refusing to proceed because it doesn’t like the mail server’s certificate. Do you have it in Nextcloud’s SMTP config by name or IP?

Normally when doing a packet capture on SMTP, I would turn off TLS so I can read the SMTP conversation in cleartext. You’ll be able to see at what step it freaks out and also exactly what error text the server sent, if any. You may also find that it works without TLS which would put you on track to finding the problem.

You were 100% correct NextCloud was freaking out so I changed it from the DNS name to the ip address and it worked but i’m so confused because I tested it with the IP address before, anyway never mind it works

Hmm… yeah and technically the certificate would never be valid against an IP address, only one of the names on the certificate. Strange.

Well this is odd, it’s stopped working again no changes were made it was working fine for a little bit