New Contacts in ios 11.4 not synct with contact app


i am using

Nextclooud Status

  • installed: true
  • version:
  • versionstring: 13.0.2
  • edition:

Operating System Debian 9
Webserver Apache
PHP Version 7.0

I installed the Calender and the Contact App and connected my iphone with ios 11.4. was not working for me but with the redirects which are descripted under “Troubleshooting Contacts & Calendar” it works fine for the first moment.

The Calender App works fine. I can create everything evereywhere and it will be synct.

But with the Contacts it is a problem. i can create new contacts in the Webinterface and they get synct to the phone. I can change existing Contacts on the phone and they will be synced with the webinterface. But if i create a new contact on my phone it dont get synct.

I found an old post here Contacts not synchronizing with iOS but in the end they had the same issue…

Is this the first time you’ve seen this error? Y

The output of your Apache/nginx/system log in /var/log/____:

error.log (but only these two)
[Fri Jun 08 23:36:40.096448 2018] [authz_core:error] [pid 9854] [client] AH01630: client denied by server configuration: /var/www/nextcloud/data/.ocdata
[Fri Jun 08 23:36:49.626320 2018] [authz_core:error] [pid 9857] [client] AH01630: client denied by server configuration: /var/www/nextcloud/data/.ocdata

access.log´(there are some 401 errors) -  <username> [08/Jun/2018:23:21:41 +0200] "PUT /remote.php/dav/addressbooks/users/<username>/contacts/c9250f0c-8267-430a-82bc-a4a92df4e07c.vcf HTTP/1.1" 204 1412 "-" "iOS/11.4 (15F79) dataaccessd/1.0" - <username> [08/Jun/2018:23:21:43 +0200] "REPORT /remote.php/dav/addressbooks/users/<username>/contacts/ HTTP/1.1" 207 2020 "-" "iOS/11.4 (15F79) dataaccessd/1.0" - - [08/Jun/2018:23:23:39 +0200] "REPORT /remote.php/dav/addressbooks/users/<username>/contacts/ HTTP/1.1" 401 1951 "-" "iOS/11.4 (15F79) dataaccessd/1.0" - <username> [08/Jun/2018:23:23:39 +0200] "REPORT /remote.php/dav/addressbooks/users/<username>/contacts/ HTTP/1.1" 207 1707 "-" "iOS/11.4 (15F79) dataaccessd/1.0" - - [08/Jun/2018:23:23:40 +0200] "PROPFIND /remote.php/dav/principals/users/<username>/ HTTP/1.1" 401 1802 "-" "iOS/11.4 (15F79) dataaccessd/1.0" - <username> [08/Jun/2018:23:23:40 +0200] "PROPFIND /remote.php/dav/principals/users/<username>/ HTTP/1.1" 207 3257 "-" "iOS/11.4 (15F79) dataaccessd/1.0" - - [08/Jun/2018:23:23:40 +0200] "PROPFIND /remote.php/dav/addressbooks/users/<username>/ HTTP/1.1" 401 1800 "-" "iOS/11.4 (15F79) dataaccessd/1.0" - <username> [08/Jun/2018:23:23:40 +0200] "PROPFIND /remote.php/dav/addressbooks/users/<username>/ HTTP/1.1" 207 5166 "-" "iOS/11.4 (15F79) dataaccessd/1.0" - <username> [08/Jun/2018:23:23:40 +0200] "REPORT /remote.php/dav/addressbooks/users/<username>/contacts/ HTTP/1.1" 207 1713 "-" "iOS/11.4 (15F79) dataaccessd/1.0"

On my phone i set the timeperiode to fetch data from automatic to 15 minutes … but this changed nothing…

Maybe someone can come up with a hint for me?

Thank you.

Hard to say, do you see errors on the phone? The logs in your post don’t really reveal on a first sight. The put command from your phone receives a 204 code, which means it received and processed all data but no answer is given. Not sure if that is normal.

For the rest, there is first an error via normal access, then the authenticated request is successful.

Can you try one of the demo servers, if you can replicate this behavior?

And on the previous iOS version it worked?

I used the free tine2.0 Version before and switch to nextcloud calender & contact Integration for several reasons. So i have no ideas if this Problem exist before .

I can try the demoserver. On my phone are no errors. Its look like that the nee contact ist only a Lokal contact and i miss the point where i choose use nextcloud for this Account

sfs … solved…

under Settings -> Contacts -> Standardaccount you can change the setting “on my iphone” to -> nextcloud url… .than it sync also new contacts.