New Backup App Setup

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 23.0.0
Operating system and version (eg, Ubuntu 20.04): Ubuntu 20.04
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.41
PHP version (eg, 7.4): 7.4.3

I have recently upgrade to nextcloud version 23.0.0 mainly because I was wanting to make use of the backup application to backup my nextcloud to an external hard drive that I have defined under external storage. I am able to access the external storage location/folder from any of the mobile devices that I have connecting to nextcloud (so I know the external storage setup is working). For reference the folder name for the defined external storage is ‘element’.

I downloaded/installed the backup app and set it up as per a video I saw - was pretty much straightforward and didn’t really need to do much on the setup screen (leaving the default values pretty much). The particular things I did were:

  • disabled encryption (do not need it)
  • exported configuration (saving the text in a file - i’m not totally sure how/when this will be used)
  • defined a restoring point location (here I selected from the dropdown the path to my ext storage area and then under restoring point location i put the name of the subfolder I created there). I put the same information under app data. It isn’t totally clear that I have done this correctly so am interested to here feedback on these 2 particular settings.

I then pressed the button ‘create full restoring point’ expecting that it would perform an initial backup. I assumed that when it does create a backup it would place it in the subfolder I mentioned in my last point. However, nothing has ever shown up there. Also, the ‘create full restoring point’ button currently seems to be non-responsive and just has a msg above it saying in red ‘the creation of a restoring point has been requested and will be initiated soon’.

So, I’m not sure I have this setup correctly and would like to know how I get these backups to start occurring. Have I setup the

I have exactly the same Problem. No new backup possible, even after uninstalling the Backup app. Also it won’t do any scheduled backups.

Nextcloud version (eg, 20.0.5) : 23.0.0
Operating system and version (eg, Ubuntu 20.04) : Docker Container running on Synology DSM 7
Apache or nginx version (eg, Apache 2.4.25) : Apache 2.4.51
PHP version (eg, 7.4) : 8.0.14

This still does not work, even after updating to Backup version 1.0.4. Please advice.

exactly the same problem here,
NC 23.0.0 running on raspberry pi4
PHP 8.0

same issue here.
Linux 5.4.0-107-generic #121-Ubuntu SMP Thu Mar 24 16:04:27 UTC 2022 x86_64
PHP Version: 8.0.17
Nextcloud: 23.0.3 - 23.0.3.2

also version 1.0.6 does simply not work at all.
please note: even IF the backup would work,
there is no implementation in the GUI to do a proper restore…
… makes it worthless for non-experts in occ and other terminal tools
This is sad because the whole decision on using a Cloud solution may depend from such basic feature like “backup AND restore”.

I also have such a problem. I moved my nexctloud to other hardware - manual copy of database and files worked. But now the backup setting does not fit any more (external drive changed…)
So I thought I can configure it new, but when loading app a popup appear that settings could not be loaded…
So I like to reset all settings of the backup app - to start set the settings again.