Network Disabled Error

Hi,

i have the same issue, the NextCould version that am using is 2.5.0, i tracked the code to know where is the error happens exactly, the line of code is here discoveryphase.cpp, after that line the an error is printed on the CMD
the following class is what generating the error networkjobs.cpp

the error is:

    07-04 15:27:30:007 [ info sync.engine ]:        Server ""
    07-04 15:27:30:009 [ info sync.csync.csync ]:   ## Starting local discovery ##
    07-04 15:27:30:011 [ info sync.csync.csync ]:   Update detection for local replica took 0.001 seconds walking 0 files
    07-04 15:27:30:012 [ info sync.csync.csync ]:   ## Starting remote discovery ##
    07-04 15:27:30:014 [ info sync.accessmanager ]: 6 "PROPFIND" "http://**********" has X-Request-ID "************"
    07-04 15:27:30:017 [ info sync.networkjob ]:    OCC::LsColJob created for "http:**********" + "" "OCC::DiscoverySingleDirectoryJob"
    07-04 15:27:30:020 [ warning sync.networkjob ]: QNetworkReply::NetworkError(UnknownNetworkError) "Network access is disabled." QVariant(Invalid)
    07-04 15:27:30:022 [ info sync.networkjob.lscol ]:      LSCOL of QUrl("http:**********************/") FINISHED WITH STATUS QNetworkReply::NetworkError(UnknownNetworkError) "Network access is disabled."
    07-04 15:27:30:024 [ warning sync.discovery ]:  LSCOL job error "Network access is disabled." 0 QNetworkReply::NetworkError(UnknownNetworkError)
    07-04 15:27:30:026 [ warning sync.csync.updater ]:      opendir failed for  - errno 5
    07-04 15:27:30:027 [ warning sync.engine ]:     ERROR during  csync_update :  "An error occurred while opening a folder Network access is disabled."
    07-04 15:27:30:031 [ info sync.database ]:      Closing DB "*********/._sync_369bd5743963.db"
    07-04 15:27:30:037 [ info sync.engine ]:        CSync run took  32 ms

any ideas? thanks

1 Like

After upgrade from an older desktop client to Version 2.5.0v2.5.0 (build 20181112) I am getting the same error message: An error occurred while opening a folder Network access is disabled.

Nextcloud_error

Same problem here…

1 Like

This issue is also mentioned for owncloud here: https://github.com/owncloud/client/issues/5977
And in bug reports for Qt: https://bugreports.qt.io/browse/QTBUG-55180
According to that conversation a workaround is described here: https://lostdomain.org/2017/06/17/qt-qnetworkaccessmanager-causing-latency-spikes-on-wifi/
Can somebody from the nextcloud devs look into this?

Then please open an issue on the bugtracker at https://github.com/nextcloud/desktop/issues, that is where bugs belong.

as there is nothing more the forum could do about it this seems to be the “solution” in this case. gonna mark @tflidd 's answer as that.

@joephein
pls be nice and post your filed github-issue here… thanks in advance

issue logged: https://github.com/nextcloud/desktop/issues/865

1 Like

I experienced the same problem after stand-by.

I have build 2.5.1 desktop client, and it says the same error “Network Access is Disabled.”

Restarting the desktop client it makes it fixed. it’s syncing normally now… however. Am seriously considering Seafile due to lack of reliabilty of sync in NC lately.

Can confirm the problem with NC client 2.5.1 with win 10 1809 on three different machines. Server is NC 14.0.6.

@rwat128, @HirIMogul

hey… the solution answers tells that there was an issue filed on github. and with s simple click you could have found out yourself that it is still open.

thats probably way faster than typing new answers with known problems :wink: