Need help with NextCloudPi installation [Details inside]


I hit activate but for the last half hour I can see the message

‘NextCloudPi not yet initialized, trying again in a few seconds …’ - There is a spinning disk / timer above the message.

But the screen has not advanced.

Should I give it more time or should it be doing something by now?

Thank you :slight_smile:

Just wondering, on your rpi,
what is output of :

cat /proc/cpuinfo

Check the ncp.log with

tail -f /var/log/ncp.log

use ctrl+c to exit, after message init done

My command line hasn’t got to a log in prompt.

It’s finished with the line

Raspbian GNU/Linux 9 nextcloudpi tty1

And I can’t log in with SSH as the connection is refused.

Should I restart my system or do I need to try something else?

You lost me there!
Restart yes

Hi @OliverV

I have restarted, then I ran ‘sudo ncp-update’ at the comment prompt, but I get the following out put…

Downloading update
Performing updates
apt is currently running. Try again later

Has the update worked?

Do I need to do something else?

Hi @_1uke

It means apt is running. It is good !
unattended-upgrades are enabled by default, that is why.
Just wait a few minutes and try again.

Please post output of

cat /proc/cpuinfo


Everything has updated fine after I waited a little while :slight_smile:

Below are the results from cat /proc/cpuinfo

Let me know what to do next - Thank you :slight_smile:

First: Visit https://192.168.x.xx/ https://nextcloudpi.local/ (also https://nextcloudpi.lan/ or https://nextcloudpi/ on windows and mac)
to activate your instance of NC, and save the auto generated passwords. You may review or reset them
anytime by using nc-admin and nc-passwd (these are available in ncp-config and ncp-web:4443).

Note: You will have to add an exception, to bypass your browser warning when you
first load the activation and :4443 pages. You can run letsencrypt to get rid of
the warning if you have a (sub)domain available.
Login to NC and check the admin panel settings and log (scroll down in left side menu)

Second: Type ‘sudo ncp-config’ to further configure NCP, or access ncp-web on https://192.168.x.xx:4443/

Hello @OliverV

I feel like my questions are getting a little silly now, so thank you for sticking with me,

When I go to 192.168.x.xx I am greeted with a login screen. (I am not asked to activate anything this time).

The log in details that I copied down yesterday are not working.

Is there a way for me to find out or reset what I type to log in?

Congrats! Your NCP instance is up and running. You did not read instructions about passwords?


I have managed to chance nc-passwd

But when I go to the nc-admin I get the message

Esc pressed

And then it returns me to the sudo ncp-config menu


Can you let me know what to do to get passed the ‘Esc pressed’ screen.

Thank you :slight_smile:

EDIT - I am login out for a few hours but I will check back soon

A plain enter should get you out and back into ncp-config
I ll be out rest of the day, have nice sunday!


Pressing enter does get me back to the ncp-config how ever if I select ‘nc-admin’ again I just see the screen that says ‘esc pressed’

I am no longer able to access nc-admin to change the password.

Should I just use ‘nc-init’ and then go back to 192.168.x.xx to restart the log in process.

Let me know the best thing to do to recover my password login.

Thank you for helping me again this weekend and hope you have been enoying your Sunday :slight_smile:

I have never seen this, so I dont know.
Maybe someone else does?

As you’re doing a fresh install, no harm in running nc-init again.


I ran the ‘nc-init’ but still getting the same thing.

I will burn the image to the card so I can go through from the beginning again.

I’ll get back to you and let you know what happens.

Thank you again :slight_smile:

Can you describe in one line what the issue is?

This could be caused by the “tempdirectory” array issue !
Should be fixed with next ncp-update
Workaround in this post

Hi @OliverV

Hope all is well in your part of the world.

I have re-installed NextCloud Pi today and it has all gone very smoothly! (Almost too smoothly) :grin:

I ran the set up wizard and selected not to use USB storage (I might change this at a later date).

I selected not to use DDNS as I plan just to use my IP for the time being until I am more comfortable with everything and decide I want to use NextCloud on a regular/permanent basis.

I also selected for NCP to try to automatically forward ports

  • Is there a way I can verify if ports have been forwarded successfully?

I am now logged in to the web interface at https://192.168.x.x/index.php

  • Can I (should I) update my username and password? - How would I do that?

  • Any other things I should immediately do now that I am logged in to the system?

Hope to hear back from you soon.

For ports; from ncp-config or ncp-web:4443 run nc-info, it will tell you if ports 80/443 are open on Rpi. To check forward from outside, log in to your router interface or visit your external ip.

Is up to you, you can view or change passwords with nc-admin for NC user and nc-passwd for ncp-web user.

The wiki in general will give you good idea of the configuration possibilities of NCP. I usually run letsencrypt and set up automatic backups. It depends on what you are using NC for, personal preferences, etc.

Hi @OliverV

I hope you are well, are you still able to help me with my set-up?

I checked the ports. 443 is open, but port 80 is closed. What can I do to correct this?

My main aim at the moment with the NextCloudPi is to set up secure access from outside my home network.

Please can you guide me with this?

Thank you again :slight_smile: