Need help with mounting SMB external storage

I’m having trouble mounting an SMB share from the same server on which I’m hosting my Nextcloud Docker image (The linuxserver distribution specifically). The documentation is a bit vague about how this works, and since Nextcloud offers no error messages here, I can’t diagnose the issue easily. I’m using global credentials, but I’ve also tried entering my server share credentials manually, with the same results. Can someone help me determine if I’m entering my mount info properly?

HOST: 192.168.x.x (The IP address of the server, but I redacted the last digits. I’ve also tried the hostname, //hostname, smb://192.168.x.x, and smb://hostname.local)
SHARE: share (Just an example name, but I’m using the name of the remote share on my server, I’ve tried with and without a / preceding it)
DOMAIN: (nothing)

I assume the issue has to do with the host, but none of the documentation specifies what format should be used for it - could someone help me out?

Host: local hostname or ip address where samba server is running such as
Share: samba share name (without /, it’s a name of share in samba.conf, not a folder, use the same letters such as capital letters if needed, not sure if needed, but anyway)
remote subfolder: directly access to remote folder, can be left empty
domain: can be domain name or workgroup, so write “WORKGROUP” or whatever name you have

add a group or usernames that are allowed to access samba
for credentials use 3rd option if you have the same credentials for opencloud and samba.

Look at your Samba logs too. Find out if it’s throwing an authentication error or something else.

If I can borrow this. Does anyone know if it’s possible to set nextcloud login by email and login to samba share by uid? It’s weird for me because when I login with email I can’t use samba shares. I have to write login info, but would like to know if it’s possible to automate this…