Need help to understand why Nextcloud docker is behaving weird during the migration

I had issue with migrating my docker folders to new server. It has already been resolved by itself but I wonder if someone could help me understand why.

Couple days ago, I had to wipe my pi4 server, and I didn’t backup my docker compose file. After reconstructing my server, I used the script from IOTstack again to re-create the docker compose file. I tried to kept the same settings, and since the html and database folders are all external in my ntfs drive, I thought there would be no issue. However, I was wrong.

I first couldn’t start the sever, and I found the log just said this at the end:
caught SIGWINCH, shutting down gracefully

Then I tried to set set a new html folder at my ext4 drive, where I run my debian, but I got stuck at the step where I have to create a “new” admin password for Nextcloud to install. Nextcloud complains the one I want to create is already exist (since I am using the old username password), but I can’t log in with it.
Just at the time when I about to give up, and set nextcloud docker back to use my external html folder in my ntfs drive, I got everything working again…

What was the problem? Why Nextcloud is doing this?

Please share more details: starting with which image you’re using and your Compose file.

Raspberry pi 4, Raspbian Bookwarm. Latest official docker image “nextcloud”. Used IOTstack to setup NextCloud.

html, config are all located at the external drive (hdd)

It’s challenging to do more than speculate without:

  • the logs from the Docker containers from the time period of your early attempts to get things running again
  • the iterations of the Compose file you used