Need help resolving Security & setup warnings


I have many Security and setup warnings that I have no clue how to resolve. I tried following the documentation links beside each warning but I don’t understand much of it, I’m not really PHP savvy at all. I’ve attached a screenshot of all the warnings.

I also have issues with my Crons Job not updated. Screenshot below of how its set up on cPanel.

Any help will be greatly appreciated.

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): replace me
Operating system and version (eg, Ubuntu 20.04): replace me
Apache or nginx version (eg, Apache 2.4.25): replace me
PHP version (eg, 7.4): replace me

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N):

Steps to replicate it:

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):


The output of your Apache/nginx/system log in /var/log/____:



Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.


Th fist orange message can easily be solved by adding the following line to the config.php file of Nextcloud (example: sudo nano var/www/nextcloud/config/config.php):
‘maintenance_window_start’ => 5,

Do not forget the comma at the end of the line!
The number 5 indicates the actual hour at which the maintenance window starts. In this case 5 means at 05:00 AM UTC! Calculate the UTC you need!

The second orange message can be solved by configuring the php.ini file:
(example: sudo nano /etc/php/8.1/apache2/php.ini)

  1. With Control+W search for opcache.enable=1. Ensure that the line is uncomment (deleting the :wink:
  2. uncommnt the line with the text opcache.interned_strings_buffer=32. Set the value to 32
  3. Search for opcache.revalidate_freq=60. Uncomment the line and verify the value. Set to 60.
  4. Search for the line with opcache.save_comments=1. uncomment the line and set the value to 1

Save the file with Control+X and ‘Y’
Then restart the webserver with sudo systemctl restart apache2

This will do the trick. Please let us know how the results are…