NCP upgrade to Debian Bullseye thread

Yes, it works :slight_smile: it properly migrates over to grub-legacy now and completes the upgrade.

root@nextcloudpi:~# ncp-dist-upgrade

This is a dangerous process that is only guaranteed to work properly if you
have not made manual changes in the system. Backup the SD card first and
proceed at your own risk.

Note that this is not a requirement for NCP to continue working properly.
The current distribution will keep receiving updates for some time.

Do you want to continue? [y/N]
Maintenance mode enabled
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'grub-legacy' instead of 'grub'
The following package was automatically installed and is no longer required:
Use 'apt autoremove' to remove it.
The following additional packages will be installed:
Suggested packages:
  grub-legacy-doc multiboot mdadm
The following packages will be REMOVED:
  grub-pc grub2-common
The following NEW packages will be installed:
  grub-legacy libc6-i386
0 upgraded, 2 newly installed, 2 to remove and 0 not upgraded.
Enabling conf php7.4-fpm.
To activate the new configuration, you need to run:
  systemctl reload apache2
Running unattended-upgrades
Unattended upgrades active: yes (autoreboot true)
Running nc-limits
Using 3103825920B for PHP
Using 6 PHP threads
Using 984276992 memory for the database
Maintenance mode disabled
Upgrade to bullseye-security successful
You have new mail in /var/mail/root

I did
systemctl daemon-reload
systemctl reload apache2
systemctl reboot
after the installation & it successfully reboots

1 Like

thanks so much

1 Like

No worries, glad I could help :+1:

Upgrade from Buster (NextCloudPi_RPi_10-08-21) to Bullseye has been done successfully on an RPI4.
After the reboot everything was working as expected.

The upgrade from NC22 to NC23 was not done.
It was necessary to upgrade manually with nc-update-nextcloud to get the NC updated to NC23.


I tried to update to Bullseye, I did a docker-compose down after that a docker-compose pull. After spinning up the new container my instance shows an 503 Error.

Maybe my ncp-report can help somehow.


On an Debian 11 new/clean curl installation I have this problem with the diference that the user is root and I´m trying to activate my user

I’m going to test that in a clean installation with the rpi image and post the result here

You can also use chown to set ownership back to www-data

Thanks but did not work

SSH error

Running SSH
New password: Retype new password: passwd: password updated successfully
Wrong salt length: 3 bytes when 8 <= n <= 16 expected.
Synchronizing state of ssh.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install disable ssh
The user pi is using the default password. Refusing to activate SSH
SSH disabled

nc-hdd-monitor does not work

Tested with Debian 11 x86_64 curl installation because I don’t have any disk available that supports smart to connecto to the rpi at the moment


Running nc-hdd-monitor

SMART Enabled.

Failed to enable unit: Unit file smartd.service does not exist.
HDD monitor enabled

completely remove the old container (don’t just stop it) and start the new one with the same volume

I already did that.
I removed the container and even removed the old image pulled the new one spinned up the new image and still got the 503 Error.

I can get into ncp-config with the new image. So I tried an ncp-update. But it downgraded me from 1.47.1 to 1.44.8.

then please share the output of ncp-diag

I just did the upgrade after I got the notification and it failed returning the following:

E: The value 'bullseye-security' is invalid for APT::Default-Release as such a release is not available in the sources 
Something went wrong. Fix it and try again

I then tried updating/upgrading again through ncp-config and it returned this:

sudo ncp-config 
sudo: php: command not found 
Running nc-update 
Downloading updates 
Performing updates 
Running nc-autoupdate-nc 
automatic Nextcloud updates enabled 
Update to bullseye available. Type 'sudo ncp-dist-upgrade' to upgrade 
sudo: php: command not found 
Broadcast message from pi@nextcloudpi (somewhere) (Sat Mar  5 17:27:13 2022):   
Update to bullseye available. Type 'sudo ncp-dist-upgrade' to upgrade 
ls: cannot access '/etc/php/7.3/fpm/conf.d/*-opcache.ini': No such file or directory 
ls: cannot access '/etc/php/7.3/cli/conf.d/*-opcache.ini': No such file or directory 
NextCloudPi updated to version v1.46.8 
Done. Press any key...

What to do?

Are you following this step?

Update to bullseye available. Type 'sudo ncp-dist-upgrade' to upgrade 

Yes, I did exactly that, which led to the first error message. When I try to upgrade again using the same command it just ends without any output.
An on the web GUI it just says “Internal Server Error” now.

How can I do that?

I tried docker exec -it nextcloudpi ncp-diag and got this error:
OCI runtime exec failed: exec failed: container_linux.go:380: starting container process caused: exec: "ncp-diag": executable file not found in $PATH: unknown

hi @furkan189, @nachoparker
i am in the exact same boat (pulled docker image v1.47.1, removed old container, spinned the new image and get 503 on both ncp and nc pages).
i get the same error as you when trying to run ncp-diag, so here is what i did :

docker exec -ti nextcloudpi bash

i get an error here because there is no execute permission on /usr/local/bin/ncp-diag

chmod 744 /usr/local/bin/ncp-diag

Here is the output of mine :

NextCloudPi version|v1.47.1
NextCloudPi image|NextCloudPi_docker_03-01-22
OS|Debian GNU/Linux 11. 5.10.92-v8+ (aarch64)
USB devices|sda 
data in SD|no
data filesystem|ext2/ext3
data disk usage|1.1T/3.6T
rootfs usage|8.7G/59G
Nextcloud check|ok
Nextcloud version|
HTTPD service|up
PHP service|up
MariaDB service|up
Redis service|up
HPB service|down
Postfix service|up
internet check|ok
port check 80|open
port check 443|open
NAT loopback|no

1 Like

I run the upgrade to “bullseye” on a RPI 4, 8GB without problems. NCP is v1.46.8 , NC 23.0.2
A few weeks ago i upgraded to PHP 8.0 . After the upgrade to “bullseye” PHP still is on v8.0
Maybee this is interessting to some others.

here is the output of docker logs nextcloudpi (raspberry pi 4 4 GB ram, raspberry pi os 64bits bullseye, container image v1.47.1, removed all previous containers, empty volume for storage) :

Making /usr/local/etc/ncp-config.d persistent ...
Making /etc/services-enabled.d persistent ...
Making /etc/letsencrypt persistent ...
Making /etc/shadow persistent ...
Making /etc/cron.d persistent ...
Making /etc/cron.daily persistent ...
Making /etc/cron.hourly persistent ...
Making /etc/cron.weekly persistent ...
Making /usr/local/bin persistent ...
Making /etc/apache2 persistent ...
Starting PHP-fpm
Starting Apache
Starting mariaDB
2022-03-07 11:17:54 0 [Note] mysqld (mysqld 10.5.12-MariaDB-0+deb11u1) starting as process 147 ...
2022-03-07 11:17:54 0 [Warning] Can't create test file /data/database/nextcloudpi.lower-test
mysqld: Can't change dir to '/data/database/' (Errcode: 2 "No such file or directory")
2022-03-07 11:17:54 0 [ERROR] Aborting

it looks like a dir/file permission issue but i don’t know what i should do to resolve it. anyone knows ? thanks.