NCP "Temporary directory is not present or writable"

ncp

#1

Hello Nextcloud community!

I have a fresh install of Raspbian 9 with the latest updates and used the one-liner to install NextcloudPi on it at https://ownyourbits.com/nextcloudpi/#supported_systems (The first one with Debian Stretch (all architectures)).

Did the setup successfully but my logfiles are showing me multiple times in a second and every second this:

|Warning|no app in context|Temporary directory {"/var/www/nextcloud/data/tmp":""} is not present or writable|2018-12-05T14:32:50+0100|
|Error|PHP|is_writable() expects parameter 1 to be a valid path, array given at /var/www/nextcloud/lib/private/TempManager.php#260|2018-12-05T14:32:50+0100|

The folder at /var/www/nextcloud/data/tmp exists for me, it was empty inside and was created from the setup itself, owned by www-data too and tried chown it again for it but still not working. Tried making a new folder called “temp” there and chown again for www-data and edited the config.php file but still doesn’t works :frowning:

I found only 2 related topics on the internet but the solutions still don’t work, the first one says that he didn’t had the folder from beginning and the other was migrating from an old instance.


Thank you for the product Nextcloud and to your attention for my issue!


#2

Hi @Bluefox1337 & welcome!

You can add this to your config.php:

‘tempdirectory’ =/tmp,


#3

Hello and thank you for your help!
I edited my config.php file and it worked like this :slight_smile:

‘tempdirectory’ => ‘/tmp’,

Should I file an issue at GitHub for this?


#4

Thanks but
No need it is already reported here