NCP restore: something went wrong (microSD full, HDD empty)

Dear all,
As a nooby, I tried to restore my NCP.
After various fresh installations to restore my NCP on my Odroid HC2 and after reading the very useful help in the forum, I’m still lost.

The NCP was always installed fresh on a microSD, datadir is directed to the SATA HDD (flag checked via SSH). The backups (including data) are located on a USB drive. Automount is activated.

There is always the same issue, no matter what I tried and changed:
After a while of nc-restore running (no matter if WebUI or SSH used), the restore stops and a generic error massage appears “Something went wrong”.
After a long while, NCP WebUI is available again but with the microSD card full and the HDD empty.
The data of the nextcloud were always located on the HDD when nc-backup-auto run and I wonder how to direct the backup data to the HDD.

EDIT: Solved the problem by complete new installation. Copied the backup to the HDD and finished the restore.