NCP: Port Forwarding not possible| open but closed | ZyXEL VMG1312-B10A

I use the latest NCP image from ownyourbits.

I’m getting absolutely insane as I simply cannot open the ports and access from the Internet.

  • Local access works well, no issue.

  • I use a ZyXEL VMG1312-B10A Router.

If I open Ports manually, I cannot reach the NCP from the Internet:

Bildschirmfoto vom 2020-12-29 15-18-35
(I’m aware that on the screenshot it’s deactivated.)

and the ports are shown as closed:

Bildschirmfoto vom 2020-12-29 14-14-12

If I enable UPnP in the router and use NCP to open the ports, I succeed and can reach the NCP from the Internet.

Bildschirmfoto vom 2020-12-29 15-18-47

Bildschirmfoto vom 2020-12-29 15-19-23

But I should “disable” UPnP as it poses a security risk.

If I do that, the ports are closed again, and I cannot access the NCP from the Internet.

What is going on?

My guess is that this is simply a useless router and I’d better buy a Fritz!box…

Any suggestions before I order one?

As this is perhaps more of a router related question, I have raised the issue on the ZyXEL forum as well. And got this answer.

Have you considered using the DMZ settings of the router?

The user guide available at talks about them because that is often a way of allowing access to certain services on LAN from the Internet.

I did not know anything about DMZ and so had a brief read on what it is. Is anyone having experience with enabling DMZ to allow server access? Is this considered safe?

Just to close this off.

I eventually bought a Fritz!box - fed up with that stupid ZyXel thing.

As a last option, I could have tried is to reset the router. This might have worked. But that only came to my mind after I ordered.