NCP on docker, filling up rootfs and Buster update confusion

Is there a reason for these files to get so huge? NCP is the only docker container at the moment. (Odroid N2 with Armbian)

sudo du -a /var | sort -n -r | head -n 10
37636092        /var
37466452        /var/lib
37351564        /var/lib/docker
37239188        /var/lib/docker/overlay2
35790720        /var/lib/docker/overlay2/04b75732e23f872f18c73e8444df90e0be3b7fc34612693a62f5973ec0136e3f
18145112        /var/lib/docker/overlay2/04b75732e23f872f18c73e8444df90e0be3b7fc34612693a62f5973ec0136e3f/merged
17645588        /var/lib/docker/overlay2/04b75732e23f872f18c73e8444df90e0be3b7fc34612693a62f5973ec0136e3f/diff
17287908        /var/lib/docker/overlay2/04b75732e23f872f18c73e8444df90e0be3b7fc34612693a62f5973ec0136e3f/merged/var
17279656        /var/lib/docker/overlay2/04b75732e23f872f18c73e8444df90e0be3b7fc34612693a62f5973ec0136e3f/diff/var
17244016        /var/lib/docker/overlay2/04b75732e23f872f18c73e8444df90e0be3b7fc34612693a62f5973ec0136e3f/merged/var/www

rootfs has 22G/29G, with only one container and maybe 100mb from data mining project.

NextCloudPi version  v1.15.0
NextCloudPi image    NextCloudPi_docker_03-14-19
distribution         Debian GNU/Linux 9 \n \l
automount            no
USB devices          sda
datadir              /data/nextcloud/data
data in SD           no
data filesystem      ext2/ext3
data disk usage      491G/1.8T
rootfs usage         22G/29G
swapfile             /dev/zram1
dbdir                /data/database
Nextcloud check      ok
Nextcloud version
HTTPD service        up
PHP service          up
MariaDB service      up
Redis service        up
Postfix service      up
internet check       ok
port check 80        open
port check 443       open
interface            eth0
certificates         sub.domain.tld
NAT loopback         no
uptime               3days

I know it’s not on buster yet, but does it come from that? I logged in because my NC was in maintanance mode, I thought I had that solved but it came back again (seems to happen every morning at 8-9)
Could it come from autoupdate and unattended-upgrades? When I run ncp-update I get:

Running nc-update
Downloading updates
Performing updates
Running nc-autoupdate-nc
automatic Nextcloud updates enabled
Update to buster available. Get the latest container to upgrade
Unknown user
Done. Press any key...

I know N2 with Armbian is a bit unstable but any clue anyone?

docker info
docker system prune -a
1 Like