NCP No updatate possible from 1.10.0 after Update to NC16.0.2

I updated recently to NC16.0.2 (something like NCP1.14.0) inside the Docker container and tried some things with Docker. In the end I wanted to just start the container again, used my usual docker command:
docker run --restart=always -d -p 4443:4443 -p 443:443 -p 80:80 -v /media/storage/data:/data --name nextcloudpi ownyourbits/nextcloudpi-armhf $IP
When starting it I arrive at NCP1.10.0 and I neither reach the NC nor am I able to update to NCP1.14.0 or a more recent version.

I’m completely lost there, thanks for any help!

Edit: Forgot the log:

Running nc-info
Gathering information...
NextCloudPi version  v1.10.0
NextCloudPi image    NextCloudPi_docker_03-14-19
distribution         Debian GNU/Linux 9 \n \l
automount            no
USB devices          sda 
datadir              /data/nextcloud/data
data in SD           no
data filesystem      ext2/ext3
data disk usage      490G/1.8T
rootfs usage         3.5G/29G
swapfile             none
dbdir                /data-ro/database
Nextcloud check      error
HTTPD service        down
PHP service          down
MariaDB service      down
Redis service        up
Postfix service      up
internet check       ok
port check 80        closed
port check 443       closed
interface            eth0
certificates         ---------
NAT loopback         no
uptime               20min

/usr/local/bin/ncp-suggestions: line 19: check_distro: command not found
You are using an outdated distro release. You should upgrade to latest Debian/Raspbian

You should enable dnsmasq to use your domain inside home

You should open your ports for Lets Encrypt and external access

You should enable automount to use your plugged in USB drive
Done. Press any key...

What things?

Fixed it!

updated everything in docker after running

  1. wget -O /etc/apt/trusted.gpg.d/php.gpg after googleing:
  2. run apt update && apt upgrade
  3. and then nc-update

I’m no expert on docker, does the script need an update?

Thank you @OliverV for your help!

  • ncp-update brings in that fix
  • you dont need to doapt upgrade`, it’s automatic by default in NCP
1 Like