[NCP] NextCloud update failed


I run NCP using the docker image on a Tinkerboard (Rockchip). Today I tried updating Nextcloud using nc-update-nextcloud but it failed.

/var/log/ncp.log says this-

[ nc-update-nextcloud ]
Current   Nextcloud version
Available Nextcloud version 15.0.5
Download Nextcloud 15.0.5...
Back up current instance...
check free space...
Maintenance mode enabled
backup database...
backup files...
backup /var/www//nextcloud-bkp_20190321_1553166162.tar.gz generated
Nextcloud is in maintenance mode - no apps have been loaded

Maintenance mode disabled
Install Nextcloud 15.0.5...
Restore apps...
 * admin_notifications
 * calendar
 * contacts
 * news
 * nextcloudpi
 * notes
 * phonetrack
 * previewgenerator
 * tasks
 * user_external
Restore data...
Fix permissions...
Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade
Set log level to debug
Turned on maintenance mode
Exception: Updates between multiple major versions and downgrades are unsupported.
Update failed
Maintenance mode is kept active
Reset log level
Clean up...
Rolling back to backup /var/www/nextcloud-bkp_20190321_1553166162-
mv: cannot remove '/data/nextcloud/data': Directory not empty
Can only restore from ext/btrfs filesystems
Rollback failed! Data left at /var/www/ncp-data.wh4E72

So, looks like I should’ve tried updating to 14 first, instead of entering “0” to default to latest.
If I try restoring from the backup, it says-

[ nc-restore ]
Can only restore from ext/btrfs filesystems

What should I do?

you will have to create a new instance with a volume that is ext or btrfs, copy the restore file and restore from there