[NCP] Mounting of USB drive fails: "unknown filesystem type 'btrfs'."

Hello everyone :slight_smile: New day, new problem :wink:

Just wanted to start fresh with my new Raspberry Pi 4 and a 375GB WD USB drive.
Installed NCP without problems and went to the web interface (first tried the wizard) to format the connected drive. That apparently worked:

[ nc-format-USB ]
/dev/sda: 8 bytes were erased at offset 0x00000200 (gpt): 45 46 49 20 50 41 52 54
/dev/sda: 8 bytes were erased at offset 0x5752affe00 (gpt): 45 46 49 20 50 41 52 54
/dev/sda: 2 bytes were erased at offset 0x000001fe (PMBR): 55 aa
WARNING: failed to open /dev/btrfs-control, skipping device registration: No such device
Drive sda formatted successfuly and labeled myCloudDrive

What did not work was the mounting of the drive afterwards. That failed through the wizard so I tried to do it manually:

pi@nextcloudpi:/ $ lsblk -f
NAME        FSTYPE LABEL        UUID                                 FSAVAIL FSUSE% MOUNTPOINT
└─sda1      btrfs  myCloudDrive e8064185-b13c-472c-91e0-3565adc70e49
├─mmcblk0p1 vfat   boot         5203-DB74                             199.9M    21% /boot
└─mmcblk0p2 ext4   rootfs       2ab3f8e1-7dc6-43f5-b0db-dd5759d51d4e    4.7G    28% /
pi@nextcloudpi:/ $ sudo mkdir /media/USBdrive
pi@nextcloudpi:/ $ sudo mount /dev/sda1 /media/USBdrive
mount: /media/USBdrive: unknown filesystem type 'btrfs'.

Apparently the filesystem of the freshly formatted drive can not be recognized by the Pi. How is that possible? Or is there anything else I missed?
@nachoparker @OliverV

Okay, after updating to the newest NCP version (1.20.7) the drive is mounted correctly and moving the data directory worked fine. :slight_smile: