NCP error -- could not connect to the appstore

Could not connect to the appstore or the appstore returned no updates at all. Search manually for updates or make sure your server has access to the internet and can connect to the appstore.

The Pi is perfectly connected to the internet and i can run the manual update commands in terminal
When in Apps and clicking on the categories, “No apps available for your version” or something like that.

Nextcloud 16.0.5 with all updates (NCP 1.18.0)

Possibly content of logs might contain clues.
Maybe post content of

sudo ncp-report

via pastebin or similar.

Here’s the Pastebin link:

I have enabled


It will look for and perform updates daily.

did you try run


Maybe app store temporarily not available.
I’ve had to download an app manually, unpack and place in apps folder, only once or twice.

Which app are you trying to update?

Yes, I also have automatic updates enabled. nc-update-nc-apps just runs with no messages, except Done.

Just now I went to the browser to check if I can access the apps categories. Now it works! I can see the apps, already installed and those not installed. This did not work before, I got just an empty screen.
It seems the problem has been solved by itself, somehow.