Ncp-dist-upgrade fails

i am running ncp on stretch for a very long time and since ncp-update doesn’t seem to work anymore on stretch i thought i will give ncp-dist-upgrade a chance before physically visiting the server to make a fresh install
but i get this error:

/usr/local/etc/ Zeile 19: ip ist nicht gesetzt.

Has nobody a hint why this error is produced?
The Server definitely has an ip…

what does this mean

That is a very good question.
Right after i run ncp-dist-upgrade i get this error.

Translation is probably: /usr/local/etc/ line 19: ip not set

That is the beginning of i marked line 19 with “*”


# NextCloudPi function library
# Copyleft 2017 by Ignacio Nunez Hernanz <nacho _a_t_ ownyourbits _d_o_t_ com>
# GPL licensed (see end of file) * Use at your own risk!
# More at

export NCPCFG=${NCPCFG:-/usr/local/etc/ncp.cfg}
export CFGDIR=/usr/local/etc/ncp-config.d
export BINDIR=/usr/local/bin/ncp
export NCDIR=/var/www/nextcloud

  [ip]=1 [dnsmasq]=2 [nc_domain]=3 [nextcloudpi-local]=5 [docker_overwrite]=6
  [nextcloudpi]=7 [nextcloudpi-lan]=8 [public_ip]=11 [letsencrypt_1]=12
*  [letsencrypt_2]=13 [trusted_domain_1]=20 [trusted_domain_1]=21 [trusted_domain_1]=22)

command -v jq &>/dev/null || {
  apt-get update
  apt-get install -y --no-install-recommends jq

Fixed it!

i made a copy of the and removed this.

  [ip]=1 [dnsmasq]=2 [nc_domain]=3 [nextcloudpi-local]=5 [docker_overwrite]=6
  [nextcloudpi]=7 [nextcloudpi-lan]=8 [public_ip]=11 [letsencrypt_1]=12

after upgrading i copied the file back, added some sources removed all php and reinstalled it with tons of modules and in the end it worked again.

only thing is, that ncp-update still gives me the upgrade advice. :man_shrugging: