NCP: Broken update from 20.0.4 to 20.0.5

I updated my ncp instance’s NC from 20.0.4 to 20.0.5 (using ncp-update-nc 20.0.5) and there were several Apps disabled (most notably Deck and NextCloudPi). I tried forcibly enabling them but they didn’t worked correctly so I downgraded by restoring the backup done before the upgrade.

Looking at the NC admin settings, it says NextCloudPi is not supported in 20.0.5:


Is there anything that can be done to upgrade? I find it very strange that an upgrade to a new bug/security release can be incompatible and is extremely unfortunate to have blockers to upgrade to the latest security update releases.

Any suggestions are welcome. Thanks!

There’s something funky with that upgrade, and it doesn’t seem to be NCP specific.

We will not doing automatic upgrades until this is figured out, so we are staying in NC20.0.4 for the time being.

Thank you for NCP. I’m only in my first few days of using NextCloud. NCP made it possible for me to have for the very first time a drop-in replacement for 3rd party cloud storage.

I like that NCP is staying in NC 20.0.04 until the issue is sorted out.

It would be good for NC to have an option to test if something breaks in one’s existing setup before applying a NC update. If the option is already there I have not seen it. Is there any room to have this option within NCP while NC doesn’t have it yet?

1 Like

Just turn on autoupdates in ncp-web or upgrade manually using version 0. That way you will only get what has been tested to work first.

Thanks for the clarification. Is there any NC or NCP issue I can check or subscribe to where the issues with this update are being reported / investigated?