Ncp-automount mounts external drive as root instead of [user]

I have a NTFS USB HDD connected to my nextcloudpi, but it is mounted as root with root permissions emulated through the drive. I would really like to mount the drive as [user] so that I can also use other programs to interact with the data on the USB HDD.

I don’t need the hot-plug capability that ncp-automount provides, so should I disable ncp-automount and write my own permissions in /etc/fstab instead?